Lexus IS Forum banner

1 - 14 of 14 Posts

·
Premium Member
Joined
·
13,297 Posts
Discussion Starter #1
i recently just replaced a bulb in my gauge cluster because it blew out. now that i replaced it, when i put everything back together, the mpg gauge, the speedometer, and the odometer doesn't function anymore. i also noticed my gas meter is somewhat messed up too.

btw, i tried searching but didn't come up with anything. i have loads of rep points like usual to give away. help me out!!!
 

·
Registered
Joined
·
295 Posts
^^^ If that doesn't work, of course you can try the fuses. I replaced mine, last week and I ran into every known scenario. Blew a fuse, changed it. Then replaced the bulbs, to find out the new bulbs were deffective. Changed the bulbs with other "new ones" and it worked fine. G/L.
 

·
Premium Member
Joined
·
13,297 Posts
Discussion Starter #6
^^^ If that doesn't work, of course you can try the fuses. I replaced mine, last week and I ran into every known scenario. Blew a fuse, changed it. Then replaced the bulbs, to find out the new bulbs were deffective. Changed the bulbs with other "new ones" and it worked fine. G/L.
where is that specific fuse located?

+rep+
 

·
Registered
Joined
·
295 Posts
where is that specific fuse located?

+rep+
If I'm not mistaken, all bulbs for the lights of the dash are on the driver's side kick panel. There is also a fuse and relay box right in front of the battery. I cannot remember the specific number, but there is a fuse in there that cannot disable numerous things in the cars electronics. That can sometimes be the fault of your problem.

My problem was in the kick panel. I actually wen thru them twice. However, I was in pretty low light and the next day I looked again, and I could barely notice it. It was more in the corner (to the left or right) rather than the typical split from the middle.

Hopefully this helps out. But definitely don't make the mistake I made by checking in low light conditions with a flash light. I'm not even going to mention what I could've saved from the stealership by checking in the daytime again before I took it in to be checked out. :pissed:
 

·
Registered
Joined
·
206 Posts
I am having the same problem. My Odometer, rpm meter, mpg meter and speedometer are not working. Everything else is. Does anyone have any more specifics on the fuse in the kick panel that controls this?
 

·
Registered
Joined
·
206 Posts
Its broken again. The fuses are labeled behind the plastic cover. How much are these fuses, does anyone have the part number?

Because unplugging and replugging it back in temporarily fixed it what does this say about the problem?
 

·
Registered
Joined
·
206 Posts
The problem was the ground wire that attaches to the frame and metal bracket near the shifter. I removed my dash and the metal bracket and reattached the ground the frame (no longer attached to the metal bracket).

When I reattached the metal bracket so I could reinstall my dash the instrumental panel started working again.
 

·
Registered
Joined
·
9,403 Posts
may want to *carefully* spread the pins open a bit, and use a little dielectric grease on the connector. That'll give a better connection. Just check everything before you button it all back up... check the functionality before you screw it all back together, ya know?
 

·
Registered
Joined
·
206 Posts
My lights on the dash do not turn on at night when i turn on the headlamps. I have removed my stereo amp and speakers. I wonder if that has anything to do with this.
 

·
Registered
Joined
·
206 Posts
Gauge Cluster Lights Never On

The night time lights on my gauge cluster do not work anymore. I am pretty sure this is no the bulb or the connection. I have removed my stereo system and pretty much the entire interior besides the dash and AC unit. I can't see how fast I am going at night. I wonder if anyone here is smart enough to know how to fix this.
 
1 - 14 of 14 Posts
Top