Lexus IS Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
642 Posts
Discussion Starter #1
Hello all, just want to get some input from owners of their "more recent", stage 2 , 2.5 and 3 kits with the haltech standalone who had their turbos installed in-house.

What issues/problems have you come across since it was installed? Been doing research for a looooooong while now and as i see more and more IS's on the streets with the "same common" upgrades, i am ready to invest $1x,000 and set the appt. for the end of Sept since they are booked til then....with all the options: Dragon TC, VB upgrade, tranny cooler, 3" exhaust,etc...

Spoke to Mo regarding the gas gauge problem i've read from researching over the months and was told there is still NO fix because of the bigger injectors, so i am stuck with that. Do you guys get CELs, and what for ? and what exactly is a "misfire" which causes the CELs? cause Mo told me some owners have experienced it. Thanks, Steve
 

·
.net superior m.f.
Joined
·
23,266 Posts
Redline just got his Turbo - i think stage3 back from SRT this weekend. he doesn't post on here much these days. But I got to see how fast that m-f'er was this weekend. We played with many cars on I95/I495 together!!

he had no problem walking away from my turbo GS300!!

PS, when i had my turbo IS300 I had PFS fix the gas gage. they said they 'recalibrated it' - but I don't know what that fix entailed. now i'm having the same problem on my GS.
 

·
Registered
Joined
·
2,573 Posts
My gas gauge worked with my 850's, buy my kit for a fraction of that kit and have a working gas gauge lol
 

·
Registered
Joined
·
3,533 Posts
my gas gauge works given i am below 3K rpm.

the moment i go past that point, it stops working lol
 

·
Registered
Joined
·
556 Posts
my gauge works, just that it doesn't tell me where the exact level of gas is in real time. it just drops from full tank, to 3/4 tank, then to 1/2 tank, then 1/4 tank lol. i've been able to live with it so far. no biggy :)
 

·
Registered
Joined
·
3,533 Posts
G0ddang said:
my gauge works, just that it doesn't tell me where the exact level of gas is in real time. it just drops from full tank, to 3/4 tank, then to 1/2 tank, then 1/4 tank lol. i've been able to live with it so far. no biggy :)
same deal here.
but if i drive below 3K rpm all the time, the gauge works.

is it the same for you?
 

·
Registered
Joined
·
556 Posts
i normally shift 3k+, so i never noticed it... hmmm... i'll try driving below 3k for a while and see what happens.

its when i switched to e6x that my gauge started acting like this. back on emanage i never had this problem.
 

·
Registered
Joined
·
8,661 Posts
Disconnect your battery, press on the brake, clear the ecu. Wait 10-15 minutes. Put the car in the ON position and see if the gas gauge has moved.

The way I recalibrated the gas gauge was doing this at the gas station, the gas gauge returned to the actual reading (very low, below 1/4 tank). I then filled up the gas WITH the key in the ON position. If you don't keep it in the on position, then it doesn't recalibrate. Not sure if this is exactly your problem...but that worked for me when I had my IS300T
 

·
Registered
Joined
·
3,398 Posts
What lil' IS said works but only resets it with how much you have in the tank. I dont believe it fixes but as a way to check (i could be wrong, didnt work w/my car). Just reset your trip gauge each time you fill up and refuel around 250-300 miles. You get used to it not working. As for the CEL's i get them but i'm not exactly sure what for. I can disconnect the negative terminal of the battery and reset it and sometimes it will stay off for a week or two, sometimes only a few days.
 
1 - 9 of 9 Posts
Top