Lexus IS Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I just bought my third 2001 IS300. In the mood to get it all prepped for me I decided to get into the engine bay and detail it. I thought I followed the rule when I detailed it to prevent this from happening but clearly something went wrong. I covered the center with a trash bag and covered the intake with a bag. I then used the shower mode on my hose (not a pressure washer) and lightly sprayed the parts I was cleaning. It ended up getting dark so I never even cleaned the main block so we can rule out water in the spark plug wells. I swapped MAFs and ignition packs just to see if that was the issue and that didn't work. It's idling high and won't pick up power until it's past 3500 rpms. The whole engine shakes when I turn it off. I'm stumped on what could be causing this issue. If it helps I also added radiator fluid while I was in there. Does anyone know what might cause this? Should I just let it dry out for a couple of days? Can I drive it to dry it out without causing damage? Any help is much appreciated. Thanks in advance.
 

·
Registered
2002 Lexus IS300
Joined
·
457 Posts
So did you get water on top of the engine? Did you get water in the MAF? Water into the ECU box or wiring?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
So did you get water on top of the engine? Did you get water in the MAF? Water into the ECU box or wiring?
Definitely not on top because of the bag, it was bone dry. I swapped MAFs so that wasn't the issue. Wiring maybe but nothing was jetted right into the harness.
 
1 - 7 of 7 Posts
Top