Lexus IS Forum banner

1 - 20 of 25 Posts

·
Registered
Joined
·
123 Posts
Discussion Starter · #1 ·
i just got done installing my pro 1 racing headers for my 03 is300.. and my engine light keeps coming on? i know that when u take off the stock headers there was a catalac converter ones.. and the new headers dont have one.. so i guess the codes are reading it, and thats why the engine light comes on..also the trac.. controll off button keeps flashing when the check engine lights on? why does the light also come on? is there anything i can do to get the engine light off without taking the bulb out...
 

·
Registered
Joined
·
3,506 Posts
Keep resetting the ECU. You'll probably have the CEL come on about every 100-500 miles there after. It doesn't mean anything is wrong, it just means that the car has no idea what the hell the header is. The only remedy is to buy an Apexi S-AFC and get it tuned, that way it over rides the ECU and all is well.
 

·
Registered
Joined
·
1,573 Posts
Do you have the O2 simulators if not then the CEL will always come back. The ecu is not reading the O2 sensors and that is throwing the CEL. If you have the O2 sims then it's an A/F problem most likely.
 

·
Registered
Joined
·
34 Posts
Just make sure the 02 sensors are tight on the header, sometimes u can get an extra 1/4 turn on them and that can make a difference, but you do nned a 02 simulator from lance or someone to get rid of the CEL for sure thats a definate. as far as the trac button flashing, i dont know. i'll ask for you though.
 

·
Registered
Joined
·
424 Posts
The Trac keeps flashing because of the code that 02 sims are throwing because of you adding the Header. It will do it untill you add an 02 sim or change back to your stock header. Since mine is flashing because I don't have an 02 sim I've noticed that my car breaks loose now. So be carefull in the rain when you think your trac will cut on and reduce power it may not now because of it flashing, but maybe its just with the 5spd or something.

Hope that helps some

Jusitn
 

·
Registered
Joined
·
34 Posts
Just dont let the problem go on much longer because if it is flashing the trac light and the traction control is cutting out, you can really mess yourself up if you hit a turn with speed expecting the trac control to kick in. i can probably get you a 02 simulator from lance for cheaper than what he sells it for, hit me with a PM if your interested. goodluck
 

·
Nygmatic
Joined
·
2,683 Posts
the CEL is due to "inefficient catalytic converter" code. the TRAC subsequently shuts off just in case to prevent engine damage had the cats really been damaged.

you can fix the CEL with a simulator. the SAFC will not get rid of this code. the SAFC gets rid of the lean code after installing a large intake (SRT or Injen Gen1).

yes, be careful with trac off. you will find yourself being able to loosen the rear much easier in the middle of turns. its a two fold system. first trac is off, second you have more power from the headers, just be careful until you get the sims in.
 

·
Guru of Supercharged ISs
Joined
·
8,744 Posts
welcome to the CLUB...... :wink: :roll:


PS ...I too have teh header & the CEL but No problem whatsoever with the Trac. Control...!?!


.... .mabey that's just cuz the 1st thing i do when i get in the car nowadays is turn that mutha OFF!! :lol: mabey i've just never noticed??


but really i had NOT heard of that issue popping up also with the installation of a header..... :-? that is a new one to me ...

e
dgy
 

·
Nygmatic
Joined
·
2,683 Posts
maybe is a difference with ECU's

huskers what year is your car? what tranny?

mine is 2003 manual.
 

·
Registered
Joined
·
424 Posts
Frydryce said:
maybe is a difference with ECU's

huskers what year is your car? what tranny?

mine is 2003 manual.

I'am with you man it might be the different ecu's because I also have a 03 Manual, and have the blinking trac light and I beleive Edgy has an 02. Might be something to check into.

Justin
 

·
Registered
Joined
·
61 Posts
Same problem

I have the same issue with my 03 manual. With headers and a race pipe I manage to throw a check engine light which triggers the trac control light to start blinking. I have an OBD-II code reader and the same codes (P430 and P420) appear each and every time I go to clear them. It's all because of the O2 sensors and ECU senses a deficiency in the air/fuel mixture. No big deal if your running without cats. It just means your not so environmently friendly. Also, the traction control gets disabled, its all part of the safety features, so yeah, be careful with the traction off in turns unless you have some sticky tires.
 

·
Registered
Joined
·
7,122 Posts
huskers33083 said:
i just got done installing my pro 1 racing headers for my 03 is300.. and my engine light keeps coming on? i know that when u take off the stock headers there was a catalac converter ones.. and the new headers dont have one.. so i guess the codes are reading it, and thats why the engine light comes on..also the trac.. controll off button keeps flashing when the check engine lights on? why does the light also come on? is there anything i can do to get the engine light off without taking the bulb out...
I have the same Pro-1 Header, XERD Race PIpe and GReddy Evo System. I have an Auto as well.I have yet to get a CEL light.
I did get 1 when I inadvertantly started the car without the OS2 sensor in the XERD (too excited to do a double check) but I just reset the ECU and tighted up the OS2 sensor. I've posted a question regarding these OS2 simulators before, as I've yet to get this CEL come on due to headers, race pipe. When I had put on my Injen intake, curiousity got the best of me so I took the filter off and revved up real high. Boom, CEL, but reset the ECU, and placed the filter back on and no more CEL.
So..
1. Check the sensors, make sure they are screwed on tightly.
2. If you had disconnected the harness of the OS2 to remove the stock manifold, check to make sure these are plugged back in.
3. Check your gas cap (I know I know, but I've heard it will cause a CEL if the cap isn't securely tightened.)
 

·
Registered
Joined
·
903 Posts
contact a shop and ask them to find a o2 simulator that can give out the correct codes for your car. i know there are a couple out there that work on it, but dont remeber there names/brand. they were about $50-55.
 

·
Registered
Joined
·
328 Posts
damn, i am about to install a header but never knew there is this problem. if i get a computer such as hks fcon or trust e-manage, would i still need the O2 sensor?
 

·
Registered
Joined
·
328 Posts
damn, i am about to install a header but never knew there is this problem. if i get a computer such as hks fcon or trust e-manage, would i still need the O2 sensor?
 
1 - 20 of 25 Posts
Top