Lexus IS Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
1,766 Posts
Discussion Starter · #1 ·
hey guys, i seriously need help, after last night, my car randomly lost all power, i cant even get it over 45mph. RPM is able to go over 3k, but the engine gets really loud. There is a hissing sound thats really loud right under the engine, and my car sounds like it is running on open headers or somethings, its so god damn loud, but its not moving. car creeps when the engine is roaring. no CEL or or any light is on. When i tried starting the car, it would crank but the rpm won't jump, it would crank over but very silently like barely making it. any ideas what might be wrong?? a vaccum hose under car busted?? bad alternator?, bad fuel pump? thanks a lot guys.
 

·
Registered
Joined
·
1,766 Posts
Discussion Starter · #5 ·
ok guys, i found the hiss, it was coming between the top of y-pipe and the end of catylic converst?? u kno where those 2 circle are, well, it looks like on of the 2 are fucked up? no wonde ri been getting really gassy smell, but the meshy stuff is sticking out og the hoole wtf is that?
 

·
Premium Member
Joined
·
52,297 Posts
2001LexusIS300 said:
ok guys, i think i foudnt eh brokem, one of the 2 catylict coverts int eh front were totally fucked, so i totally gutted it, but hey guys, it is save to drive with it gutted?? or will it kill my 02 sensor?
What do you mean, totally fucked?
 

·
Registered
Joined
·
73 Posts
I had a converter fail on a past car once and it was the same thing: sounded like a vacuum cleaner and had no power.

You'll at least new 1 cat. Take it to the dealer to check out and price out, then go Midas and see if they can do anything. I had Midas replace mine because they wanted $150 for the converter while GM wanted $550.

Again, I'm uncertain of the layout of the cats on the IS300 (don't have one now) but that's most likely the cause, especially since you saw the material all busted up in it.

Oh yeah, (edited to add this), once I got the converter replaced, it had more power than it had in a long time, probably because it was slowly robbing power for quite a while before total failure. And, it also showed me that the muffer was going, as it got a LOT louder after replacing the converter. I think the bad converter was killing the exhaust flow that bad.
 

·
Registered
Joined
·
1,766 Posts
Discussion Starter · #12 ·
thanks for the help guys, new header/catylic convertor combo going on monday... hopefully it solves everything. our cars suck, they are attached to out headers, so we would need to cut and weld a lot, so im gonna just get both front cats and headers swapped, wish me luck!
 

·
Registered
Joined
·
1,766 Posts
Discussion Starter · #13 ·
thanks for the help guys, new header/catylic convertor combo going on monday... hopefully it solves everything. our cars suck, they are attached to out headers, so we would need to cut and weld a lot, so im gonna just get both front cats and headers swapped, wish me luck!
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top