Lexus IS Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
135 Posts
Discussion Starter #1
14,000 miles, ecu/trac update completed. In the last 2 weeks, twice while I was refueling, my engine shook and quaked but came back to life before it died. Yesterday as I was slowing to turn left, it practically quit for just a brief second I thought I was in the rodeo on the bull right as they open the gate. I heard a pretty loud, "THUMP!" My kids got all excited because it was almost like I cut the motor off and put on the brakes for a split second. Then everything picked up and worked fine. Any ideas?
 

·
Registered
Joined
·
18 Posts
Yes, Had the same problem. Take the car back to the dealer and explain that the problem is still present. I work at a toyota dealer and read the ecu bulliten. The bulliten is actually for a throttle responce problem, not a shift concern. I spoke with the Toyota field engineer, and my dealer about this. My dealer actually replaced the TRAC ECU. It has taken care of about 99% of the problem, but it still does it sometimes, I think this may just be "Lag" in the ECU programming, basically the computer cannot react fast enough to the slowing down, the quick reacceleration around turns. I actally had to test drive with a technician at the delaership to show him what the actual problem was. I reccomed to do the same, and reccomed that they replace the ECU.
 

·
Registered
Joined
·
135 Posts
Discussion Starter #3
Would your car almost stall out at idle in park? i've had the ecu/trac updated.
 

·
Registered
Joined
·
782 Posts
did you reset the car? take negtive wire from battary and unplug for few min (it will reset all system) maybe that will help...

helped me while ago when i got my ECU?TRACK update done.
 
1 - 4 of 4 Posts
About this Discussion
3 Replies
3 Participants
glex
Lexus IS Forum
Community dedicated to Lexus IS Enthusiasts. Come in and enjoy our articles, galleries and information on aftermarket parts for the IS300, IS250, IS350.
Full Forum Listing
Top