Lexus IS Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3,155 Posts
Discussion Starter #1
i cant start the engine. when i turn my keys, (like average normal person) the battery cuts out. i wait for about 30 seconds, the clock is reset and then the car starts. i can hear the stereo trying to shuffle(?) the cd's, prolly b/c the battery is reconnected and disconnected continually.
my battery is not dead though, i know i didnt leave anything on.

its my third time...
is it battery connection failure?
im confused...
 

·
Registered
Joined
·
12,157 Posts
either you tripped the anti theft thing, or your battery is being drained, whether you left something on or not. the starter could also be screwed, but i doubt that. unless you screwed with the terminal connections, i would doubt that also, take it to the dealer.
 

·
Registered
Joined
·
3,155 Posts
Discussion Starter #3
ha, prob. solved.
thnx to my lazyness...
i called lexus roadside assistance, and told them i have no idea wtf happend to my car
a towing truck came from "AAA" (?)
he tried to jump-start my car. he put those clamps onto my batt., the connection came off...
he and i were like, "uhhh......." for 10 seconds.
so the guy just tightend the bolts, everything was good and set.

later, i found out that from the last inspection i had on my IS, there was a thing called "protective battery pad".
the f***in' technician f***in' forgot to tighten those f***in' battery connection!!! after he screwed around w/ my batt.!!!
no wonder why my batt. gauge was a bit off!!!

anyways, everything is set and good to go...
got my prob. solved
 

·
Registered
Joined
·
12,157 Posts
congrats.


Originally posted by blueIS:
ha, prob. solved.
thnx to my lazyness...
i called lexus roadside assistance, and told them i have no idea wtf happend to my car
a towing truck came from "AAA" (?)
he tried to jump-start my car. he put those clamps onto my batt., the connection came off...
he and i were like, "uhhh......." for 10 seconds.
so the guy just tightend the bolts, everything was good and set.

later, i found out that from the last inspection i had on my IS, there was a thing called "protective battery pad".
the f***in' technician f***in' forgot to tighten those f***in' battery connection!!! after he screwed around w/ my batt.!!!
no wonder why my batt. gauge was a bit off!!!

anyways, everything is set and good to go...
got my prob. solved
 

·
Registered
Joined
·
449 Posts
Originally posted by blueIS:
i cant start the engine. when i turn my keys, (like average normal person) the battery cuts out. i wait for about 30 seconds, the clock is reset and then the car starts. i can hear the stereo trying to shuffle(?) the cd's, prolly b/c the battery is reconnected and disconnected continually.
my battery is not dead though, i know i didnt leave anything on.

its my third time...
is it battery connection failure?
im confused...
---------------------------------------------

I knew it, always use the "KISS" method, Keep It Simple Stupid. Has to have been the BAttery terminals, just from your description alone. Another satisfied customer!!!!!!!
 
1 - 5 of 5 Posts
About this Discussion
4 Replies
3 Participants
civic Si-r
Lexus IS Forum
Community dedicated to Lexus IS Enthusiasts. Come in and enjoy our articles, galleries and information on aftermarket parts for the IS300, IS250, IS350.
Full Forum Listing
Top