Lexus IS Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
when I try to engage my cruise control on the highway the "cruise" light on the dash lights up for a quick second and begins to flash/blink on and off, It wont engage at holding the speed, the light will continue to blink/flash on and off with no functionality.

I disconnected the negative battery terminal over night and let the car sit thinking it would reset the problem but, the flashing/blinking cruse light problem is still here.

Is anybody else experiencing this problem?
 

·
Registered
Joined
·
51 Posts
Do you have any CEL? I had that issue once and only once. Ended up being my brake light switch fuse went bad. That circuit is used in conjunction with cruise control, to turn off cruise control when you apply the brakes. Theres fuse box under the hood and also inside the car where your feet would be.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #4
Do you have any CEL? I had that issue once and only once. Ended up being my brake light switch fuse went bad. That circuit is used in conjunction with cruise control, to turn off cruise control when you apply the brakes. Theres fuse box under the hood and also inside the car where your feet would be.
I will check this out! and no i dont have a error for the CEL
Thanks
 

·
Registered
Joined
·
2,551 Posts
The stepper motor is the control. Have you checked the connector at the throttle body? Other than that. If there is an issue with the ABS system. Like sensors or brake switch. Also the switch on the column could be an issue. You need to do so checking.
 
1 - 6 of 6 Posts
Top