Lexus IS Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hey all,

First post here, but had a quick question. In October I replaced my spark plugs, coil packs, and Valve Cover Gaskets. Car's been running fine, but did an oil change, and it started miss-firing. Pulling a p0305 code, so I went and took everything a part, and sure enough all plugs are wet again. A mechanic friend told me I had should have also replaced the "plug hole seals" but, I'm not entirely sure that's relevant with this car. Unless there is something I'm missing. Any help would be appreciated. I went through the search function, but I'm mainly seeing valve cover seals as the resolution.
 

·
Registered
Joined
·
1,909 Posts
Hey all,

First post here, but had a quick question. In October I replaced my spark plugs, coil packs, and Valve Cover Gaskets. Car's been running fine, but did an oil change, and it started miss-firing. Pulling a p0305 code, so I went and took everything a part, and sure enough all plugs are wet again. A mechanic friend told me I had should have also replaced the "plug hole seals" but, I'm not entirely sure that's relevant with this car. Unless there is something I'm missing. Any help would be appreciated. I went through the search function, but I'm mainly seeing valve cover seals as the resolution.
I would say bad gasket install. The only other time I have seen an issue. Would be crank case pressure getting to high. Basically the PCV was not working right.
 
1 - 5 of 5 Posts
Top