Lexus IS Forum banner

21 - 40 of 181 Posts

·
Registered
Joined
·
155 Posts

·
Registered
Joined
·
192 Posts
ok, so got a call back today, they finally figured out the solenoid wasnt the issue...

apparently the last owner didnt change the oil regularly and the broken down oil created a varnish inside of my engine that was building up on the new solenoid and blocking it, setting off the CEL...

they suggested trying synthetic oil and BG MOA (which they put in my car)
and other than that the next step would be replacing the engine if all else fails

at this point im going to try these smaller solutions and keep driving the car and try to get it past emissions since they said this problem will only effect high end performance until the engine just goes completely and id be at the same point as i am now (as far as replacing the engine goes)

any suggestions for solutions or good extended vehicle warrantys that would cover this?

Toyota has an engine top cleaner device that helps wuite a bit, as far as not changing the oil regularly that would be why your getting the code, their is an old trick you could do, but have someone professional do it, is to use 5w-30 tranny fluid. you can run it through your engine for about 10 seconds with an oil filter on it, then drain the tranny fluid, remove the filter, replace with full synthetic oil and new filter, then drive for about 1000 miles and perform another oil service. ive done this to quite a few older cars and it works pretty well, it does smoke a little but its normal, just burning off the nasty deposits in your block
 

·
Registered
Joined
·
14 Posts
Trouble Codes P0016 and P0037

Ive got a check engine light with the trac flashing. Pulled the codes and I got two P0016's and a P0037.

P0016- Crankshaft position - camshaft position correlation bank 1 sensor A
P0037- HO2S Heater control circuit low (bank 1 sensor 2)

I know the P0037 code means a faulty Oxygen sensor and I plan on replacing that tomorrow. What I dont know about is the P0016. Should I be concerned about this? Car is running like a champ. Talked to the service department at Toyota and they said it was most likely a hickup because P0037 usually causes the car to run like crap. Reset the ECU and they came right back.

Also, can I get a Ox sensor (PN 89465-53200) at toyota.
 

·
Registered
Joined
·
222 Posts
is there a manual way of finding the codes without a scanner?
Just go to an auto parts store and they'll lend it to you to get your codes. That's about as manual as it gets. Haha

I have p0442 and p0446. I checked everything for the most part. I think I may have to have my Evap system thoroughly checked by my bro in law's shop and possibly change it.
 

·
Registered
Joined
·
222 Posts
Sorry, I don't know about it. I say this because I know it's frustrating to not get any answers at all. Lol, did Toyota not say anything about what may be required? You might want to ask them what would be required since it came back on; that's what I would advise you to do.
 

·
Registered
Joined
·
601 Posts
p0442,441,446?

Took my car to autozone to get checked this morning, and it threw out these 3 codes.. can anyone explain them to me? The guy there..well.. he just didn't explain it good enough, I'm so confused!

p0441- BBEVAP system incorrect purge flow
possible:
block vapor canister
vent solenoid malfunction
purge solenoid malfunction

p0442- BBEVAP system small leak detected
possible:
failed vent solenoid
loose/missing fuel cap
purge solenoid malfunction
evap hose faulty

p0446-BBEVAP system vent control circuit
possible:
open or short circuit
poor electrical connection
faulty vent solenoid

what the heck does this all mean?!

thanks in advance =)
 

·
Registered
Joined
·
222 Posts
There are several other threads that explain all this information...try to use the search function.

To make things simple, you may need to change your gas cap. Get it tested at an auto service shop. If that doesn't work, then you may have a damaged hose in your EVAP system or, possibly, a bad VSV sensor.

I have the p0442 code and I'm currently working on getting it off, myself. My gas cap is fine so I'm left with the hoses. I'm going to smoke the system to see if anything is leaking. If that doesn't work then I'm going to have a Toyota or Lexus dealership professionally diagnose it for me.

Good luck with it!

PS: try that search function next time, it works wonders! :)
 

·
Registered
Joined
·
58 Posts
Cel

p0446-BBEVAP system vent control circuit
possible:
open or short circuit
poor electrical connection
faulty vent solenoid

That is the main problem. Its inside the Evap canister. 9 out of 10 times ita the evap canister. Check connections and hoses next to and aleaving it. Replacing the evap canister should fix the problem.
 

·
Registered
Joined
·
222 Posts
Sweet, thanks for the tip Is3Tree2002 aka hero of the day. Lol, I planned on doing that but hearing it from someone else makes me feel better about it.

I'm Ron Burgundy; you stay classy, San Diego.
 

·
Registered
Joined
·
14 Posts
I've fixed my P0037 code by jumping the wires from my working O2 sensor.

But, I still have the P0016 code (Crankshaft position - camshaft position correlation bank 1 sensor A)

I checked the resistances for the sensors and got 1.0 K Ohms for the Camshaft Position sensor and 2.1 K Ohms for the Crankshaft position sensor.

Can someone confirm these readings are correct. Both were taken with a cold engine.
 

·
Registered
Joined
·
222 Posts
So it turns out I had just installed one of the sensors backwards. A simple flip fixed my problems.
 

·
Registered
Joined
·
11 Posts
Hi im looking to buy this 2002 IS300, but the check engine light is on and it says 02 sensor is bad, and the abs sensor is shot since it gives a vibrating feeling on the brake when u apply it. please im looking for advice or a way to fix this problem.
 

·
Moderator
Joined
·
23,115 Posts
Hi im looking to buy this 2002 IS300, but the check engine light is on and it says 02 sensor is bad, and the abs sensor is shot since it gives a vibrating feeling on the brake when u apply it. please im looking for advice or a way to fix this problem.
Obviously you're going to need to replace both. You can view this thread for a location to buy the parts:

http://my.is/forums/f87/lexus-parts-websites-performance-oem-317041/

and this thread has the repair manual if you're looking to do it yourself:

http://my.is/forums/f138/here-you-go-lexus-is300-repair-manual-386133/
 

·
Registered
Joined
·
10 Posts
quick question if you have to replace one bad O2 sensor should you replace all at the same time? I just got all of them replaced due to the technician telling me its better all get replaced once one has bit the dust. So I bit the bullet and got them all replaced. My engine light went off and the trac light as well. Which was good but now its 4 days since i got that fixed and behold today when i turned on the car there were my two friends the CEL and Trac light both on. I am so pissed. I will be going back to the shop but have to wait till tuesday since tommorow is a jewish holiday.

Update when to my sears auto center, could not wait till tuesday. The code was P0453= Evap emission control to high. Well they took of the code and the CEL and Trac light went off. hopefully they stay off. Still going to take it in back tot he shop and see what they tell me. Anyone ever got that code before?
 

·
Registered
Joined
·
10 Posts
Code P0453!!

Hey guys my CEL light and trac came on. I went to get the code read and it gave out P0453 (Evap Emission control to high) Does anyone know what this might be. The shop took off the code, it has yest to return but I'm hoping it does not. Also I recently changed 02 sensors. Any feedback would be helpful.
 

·
Registered
Joined
·
10 Posts
Thanks, Well the CEL and trac just came back on today. Have to take it to the shop and see what they have to do to fix this problem. I hope is not to expensive.
 

·
Registered
Joined
·
26 Posts
Why would this O2 sensor go bad so quickly? At least to me I replaced my O2 sensor about three years ago and I just got the check engine and trac off light again. I know I have to get the code once again but I'm guessing that it is the O2 sensor again.
 
21 - 40 of 181 Posts
Top