Lexus IS Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
1,394 Posts
Discussion Starter #1
My car threw a CEL for "evaporation sensors" according to my shop. So they tightened the gas cap and it went off.

Is this actually the case?
 

·
Registered
Joined
·
1,394 Posts
Discussion Starter #4
Okay, just making sure, thanks guys. :)
 

·
Premium Member
Joined
·
6,292 Posts
That's why I always pump my own fuel... don't trust those gas jockeys to put the fuel cap right.
 

·
Registered
Joined
·
2,197 Posts
cryostate said:
Make sure you hear the gas cap click at least three times. Most cars have this happen if you don't tighten the cap.
I heard it's actually two clicks...but who's counting? ;)

Yes, as people have pointed out, it can throw a cel. I believe it's due to the pressure in the gas line. My local dealer says you'd be surprised at how many people come in with that just to realize that's the cause.
 

·
Registered
Joined
·
1,394 Posts
Discussion Starter #8
Okay guys I got gas and turned it more than 5 times, lol. And it threw the same CEL. My shop said they can't figure it out. Any ideas?
 

·
Hello World
Joined
·
3,733 Posts
Gas cap CEL?
I had a gas cap CEL when I used an aftermarket gas cap. I do not know. None of those who I know has had no gas cap cel but mine. This is what happened to me: when I got CEL a day after swapping gas cap, the Longo mechanic swapped vacuum tube(?) for $125 and CEL went off. Next day, CEL came back on and went to dealer again. This time, CEL went off, free of charge. When CEL came back on for third time, I was kind of mad and talked to general manager guy and then talked to a different mechanic. This time, the mechanic asked me where is the original gas cap and the reason of swapping to aftermarket one. "Won't allow smog check," I lied...lol. I brought the stock one back and the gas cap CEL never came on. That is what happened
 

·
Premium Member
Joined
·
6,292 Posts
MonStar1120 said:
Okay guys I got gas and turned it more than 5 times, lol. And it threw the same CEL. My shop said they can't figure it out. Any ideas?
It could be your fuel cap seal is no good.
 
1 - 11 of 11 Posts
Top