Lexus IS Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
4,322 Posts
Discussion Starter · #1 ·
Yesterday as i was driving home I all of a sudden got a check engine light out of no where. I was actually just pulling into the garage and my mechanic hooked it up to the diagnostics.... it spat out 2 codes. I forget what the codes were but it basically said that bank 1's and 2 had an error.

I used to have a XERD racepipe, but doesn't that only effect O2 #2??? basically i'm looking at o2 sensor #'s 1 and 2 possible defected. The race-pipe is off my car and has been off for approximately 6000 miles. I called Lexus dealership and scheduled an appointment... they asked me if i just fueled the vehicle and like wtf.... everybody puts fuel into their car within a few days.... :-? I didn't want to reset the ECU so that the mechanics at Lexus could have valid codes to confirm but lastnight I took my car out and noticed the CE light has automatically gone out. Correct me if I'm wrong but isn't the CE light supposed to be on until you reset the codes? wtf!!! :boring:
 

·
Moderator
Joined
·
8,849 Posts
The light may be off, but I think the last error code is still stored in the ECU.
The reason why they asked you about fueling the vehicle is if the lid is not tight, CEL will go off.
Any other MODs, such as intake? Did Trac-OFF light flash when the CEL was ON?
 

·
Registered
Joined
·
4,322 Posts
Discussion Starter · #3 ·
vlad_a said:
The light may be off, but I think the last error code is still stored in the ECU.
The reason why they asked you about fueling the vehicle is if the lid is not tight, CEL will go off.
Any other MODs, such as intake? Did Trac-OFF light flash when the CEL was ON?
I have HKS Hiper and SRT w/ ecu.. i've had those on for a while now.. i dont suspect them being the problem. Unless my ECU took a sh*t and now i'm running too lean or something. The Trac button did not flash. Usually when the lid is not tight on the gas tank.... it would spit a code but wouldn't it be a different code? I told the dealerships that the ECu was showing Banks 1 and 2 inop!
 

·
Registered
Joined
·
1,784 Posts
I think you are confusing BANKS 1 and 2 with SENSORS 1 and 2

There are 4 o2 sensors.

Sensor 1, banks 1 & 2 (pre-cat)

Sensor 2, banks 1 & 2 (post-cat)

find out which are throwing codes, then get back to us.

-C
 

·
Registered
Joined
·
4,322 Posts
Discussion Starter · #5 ·
doublins said:
I think you are confusing BANKS 1 and 2 with SENSORS 1 and 2

There are 4 o2 sensors.

Sensor 1, banks 1 & 2 (pre-cat)

Sensor 2, banks 1 & 2 (post-cat)

find out which are throwing codes, then get back to us.

-C
oh sorry. excuse my lack of knowledge. It did infact spit out 2 codes. 1 was bank 1 and the other was bank 2. So i'm guessing my sensor 1 is jacked?

Thanks for the input.
 
1 - 6 of 6 Posts
Top