Lexus IS Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hello everyone this is my first post on here, I’m stuck on a problem looking to see if anyone can help me out.. I recently replaced my oem manifold. With a Frankenstein Aristo top runners/throttle body and GE bottom runners that were mated together. I did this with the intention of going turbo soon, at the moment I have the FFIM on and the cold side pipe on, with a new MAF sensor. so it’s pretty much a Aristo manifold with a cold air intake. My big problem is that now my car won’t hold a steady idle, specially when the cooling fans turn on, it dies.
So my question is, is there a way to reset the throttle body?? or is my Ecu not compinsating for the extra air coming in?? This Frankenstein manifold was previously running on a turbo car with no problems.
 

Attachments

·
Registered
Joined
·
576 Posts
I'd check to see if you have any air leaks in the manifold/gasket and the possibility of a bad wiring connection (from you picture it looks like you have extended the wiring).
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
I'd check to see if you have any air leaks in the manifold/gasket and the possibility of a bad wiring connection (from you picture it looks like you have extended the wiring).
I sprayed everything with brake cleaner to check for a leak, no changes... some parts of the harness have been extended, I’ve double checked everything..
 

·
Registered
Joined
·
5,270 Posts
Are you using a MAF?
Is the MAF tube the same diameter as the OEM one?
Will the OEM ECU drive the FFM throttle body properly?

It sounds like a mismatch between the ECU and the throttle body and/or like you're not using a MAF.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #8
Are you using a MAF?
Is the MAF tube the same diameter as the OEM one?
Will the OEM ECU drive the FFM throttle body properly?

It sounds like a mismatch between the ECU and the throttle body and/or like you're not using a MAF.
Sorry couldn’t get back in my account, alone the ARISTO FFIM didn’t work, once I turbo the engine with that manifold everything works well! Only problem I have is that on cold start my car idles at 2000-2200rpm.. till it’s warmed up
 

·
Registered
Joined
·
1,987 Posts
Sorry couldn’t get back in my account, alone the ARISTO FFIM didn’t work, once I turbo the engine with that manifold everything works well! Only problem I have is that on cold start my car idles at 2000-2200rpm.. till it’s warmed up
I have not done this swap. But I know on the LS400 throttle body swaps I have done. They idle a bit high. Well when it is real cold. After a bit the GE ECU adjusts a bit lower. Make sure your TPS is ohmed right for the ECU you are using.
 

·
Registered
Joined
·
82 Posts
I have not done this swap. But I know on the LS400 throttle body swaps I have done. They idle a bit high. Well when it is real cold. After a bit the GE ECU adjusts a bit lower. Make sure your TPS is ohmed right for the ECU you are using.
did you do an FFIM with LS400 TB or happen to know anybody who did so?
i'm piecing the components to do that along with a piggyback and built head,
my concern is the physical space requirement of the huge TB!!
 

·
Registered
Joined
·
1,987 Posts
did you do an FFIM with LS400 TB or happen to know anybody who did so?
i'm piecing the components to do that along with a piggyback and built head,
my concern is the physical space requirement of the huge TB!!
Like I said before. I have not done this swap. (FFIM) But as to your question. I do not know if it could be done on this intake style without some serious mods. Also I am referring to the 80mm one.
http://i44.tinypic.com/33wtyrc.jpg
If you are referring to the smaller 75mm Long style throttle body. It uses the same flange I believe. This tread has a picture of it.
https://lh6.googleusercontent.com/-R3u59LpP9KY/TsVYzqd6t4I/AAAAAAAACak/fpcw4uwF9Qw/s912/IMAG0736.jpg
 

·
Registered
Joined
·
8 Posts
Discussion Starter #12
That’s exactly what’s happening, idle on cold start is 2000-2200 for 5mins and then I guess the GE ecu makes adjustments and lowers idle to 1500...it’s just annoying with a 3in turbo back, it’s pretty loud in the morning.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #13
Sorry couldn’t get back in my account, alone the ARISTO FFIM didn’t work, once I turbo the engine with that manifold everything works well! Only problem I have is that on cold start my car idles at 2000-2200rpm.. till it’s warmed up
I have not done this swap. But I know on the LS400 throttle body swaps I have done. They idle a bit high. Well when it is real cold. After a bit the GE ECU adjusts a bit lower. Make sure your TPS is ohmed right for the ECU you are using.
That’s exactly what’s happening, idle on cold start is 2000-2200 for 5mins and then I guess the GE ecu makes adjustments and lowers idle to 1500...it’s just annoying with a 3in turbo back, it’s pretty loud in the morning.
 
1 - 15 of 15 Posts
Top