Lexus IS Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter #1
ok guys so im having major engine problems and i would really appreciate any help as im really scared.

car has 152k on it. the check engine came on about 10 months ago and i got the codes read, came out to be a front o2 sensor and some weird one that had to do with a vacuum leak (p0505 and p0300 i think, ill get the exact codes when i get home). i didnt think anything of it until about a week ago i noticed the start to bounce back and forth on acceleration only at low rpm and particularly in higher gears. Now the problem has gotten way worse and i can barely accelerate, literally, and the cel now flashes when i try to accelerate and the problem happens. it feels like the clutch is slipping almost when i try to accelerate but ive tested that and the clutch seems to be fine. ehen i got the codes read about a week ago it showed no signs of misfire but it has gotten much worse since then. ive also heard a loud, sharp pop or crack when accelerating at two different times, almost so sharp i didnt think it was exhaust one time, it sounded like a crack but the second time was deff exhaust.

i barely have any tools when i live so im gona drive home this weekend to check it all out. i wamt ti clean out the tb really good, the maf, fix the 02, but what else should i check, like the valves, compression, coils all that stuff. if anyone has any input on what this could be coming from that woyld be amazing. thank you in advance
 

·
Registered
Joined
·
36 Posts
Discussion Starter #2
the problem is i have to wait until this weekend to look at everything that requires more than a wrench amd then itll be another almost 2 weeks until ill get parts and be able to put them in so any info that could help me buy parts now like coil packs or what not what be amazing
 

·
Registered
Joined
·
99 Posts
What are the actual codes now? No one can tell you what are potential solutions until they know the problem. If the cell is flashing you should not be driving the car though.
 

·
Registered
Joined
·
565 Posts
Sounds like you are running too rich, which can be caused my many things. I take it you have checked they easy stuff like air filter, air/vacuum/exhaust leaks.....?
 
1 - 5 of 5 Posts
Top