Lexus IS Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
434 Posts
Discussion Starter · #1 ·
Ok. i just got the ride back as a result of some boost leaks. shop noticed boost controller was not holding boost well at all(blitz sbc-iD). controller is now off and running on 7lb. wastegate spring. As im driving the car today with ebc off, i give it some gas and the ebc spikes up to 16(and would have gone higher if i didnt let off).My whole plan was to start adjusting the boost controller with manual mode. if its spiking with just the wastegate spring. what the hell am i supposed to do?:confused: what would cause this and how could it be solved. i bought the tial brand new with the spring so i believe its the right one.
 

·
Registered
Joined
·
5,941 Posts
Double check the spring and make sure your wastegate lines are hooked up correctly. The Blitz SBC-id solenoid has 2 lines, IN and OUT. Make sure the IN is connected to a boost source and tee'd into the side of the wastegate. The OUT connects to the top of the wastegate.
 

·
Registered
Joined
·
1,824 Posts
the other thing you can do is run a vacuum line straight from the manifold to the bottom port on the wastegate....that will tell you base pressure too.
 

·
Registered
Joined
·
434 Posts
Discussion Starter · #7 ·
Boost problem solved. it turns out something is wrong with the ebc so i ended up having a manual bc installed and will just use the ebc for a gauge and data. However, it turns out i have the same damn leaks that supposedly were fixed on monday by the original turbo installer!! ive already set an appt. saturday to get this shit finally straightened out. well see...
 
1 - 7 of 7 Posts
Top