Lexus IS Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hello,
Just completed the aristo swap in my 2003 is300. I’m using the stock aristo ecu and have a single turbo. When I start the car, the idle would drop below 500 and car would show 18+ AFR but when I rev it a bit AFR will show around 14.7 then jump back to 18+ and idle low. When I’m cruising around AFRs would stay in the 14-15 range and when I get into boost around 12-13. Seems only when it’s idling or let off throttle it would just lean out. Any pointers would be appreciated thanks.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
478 Posts
Did you do a fuel return? And if so what is the base fuel pressure?

Also where is the MAF - pre or post - turbo?

I wouldn’t boost it til you fix it. 13 is too lean. You shouldn’t hurt it at idle with no load while you’re sorting it out. Decel lean-out is pretty normal, your cruising A/F are pretty normal too.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3 (Edited)
Yea I’m using the aristo sending unit with 5/16 return line. Running Aeromotive 340lph fuel pump. Have not checked fuel pressure, using stock fuel pressure regulator.
My air flow meter is post boost connected to the pipe just before the throttle body.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
478 Posts
Okay. I’m pretty sure the MAF is pre turbo in an Aristo...now whether that’ll cause your problems I don’t know. But it might.

Aristos have an fpr on the injector rail. So that is what you’re using? I’d go for an aftermarket Aeromotive fpr, and bigger injectors. You possibly are running out of fuel on the stock 440ccs and single turbo causing leanout in boost.
 
1 - 4 of 4 Posts
Top