Lexus IS Forum banner

781 - 795 of 795 Posts

·
Registered
Joined
·
156 Posts
So after reading up a bunch, I naturally have questions.

After 8 years, what truly is the best setup for this. As in ECU set up and engine management. I know this is subjective, but from someone who has a lot of knowledge in the field ...wingzero... your opinion goes a long way.

Also I'm hazy in the wiring of this. Unless suggested otherwise, I plan on using the stock GE ECU and harness. after reading page one (and getting lost in the other 51 pages) I am under the impression that I will need to do no modification to the harness at all. Is this correct? Any plugs that are not on the harness just go unplugged and unused?

Thats it for now. I have a ton of questions but am still reading up and trying to find the answers. Those are the ones that seem to be vague and subjective.
 

·
Registered
Joined
·
4,095 Posts
Discussion Starter #782
My suggestion would be to use the IS ECU with a piggy back. Either E-manage or AEM or whatever your choice would be. Keep in mind your tuner will need to know how to tune it so that might take some weight on your decision. I've done this 3 ways now IS ECU with Piggy, IS ECU with Stand Alone and Aristo ECU only (which is where its at now) and if it matters, I will be going back to the IS ECU soon.

As for the harness, yes no real modification will need to be done, except for the extension of some connectors. Specifically the MAF. Depending on where you put it, it will need to be extended. Mine was near the TB on the GTE motor so had to extended it to reach the sensor. All connections on the harness will get used but not all the sensors on the motor will get connected. Like the MAP, VSV's for Sequential Turbo setup, etc. etc. Also the Oxygen sensors depending on how you have yours setup.

Hope that helps...best of luck!
 

·
Registered
Joined
·
890 Posts
So after reading up a bunch, I naturally have questions.

After 8 years, what truly is the best setup for this. As in ECU set up and engine management. I know this is subjective, but from someone who has a lot of knowledge in the field ...wingzero... your opinion goes a long way.

Also I'm hazy in the wiring of this. Unless suggested otherwise, I plan on using the stock GE ECU and harness. after reading page one (and getting lost in the other 51 pages) I am under the impression that I will need to do no modification to the harness at all. Is this correct? Any plugs that are not on the harness just go unplugged and unused?

Thats it for now. I have a ton of questions but am still reading up and trying to find the answers. Those are the ones that seem to be vague and subjective.
Thank you thank you thank you. Reading the thread and THEN asking the question about something that was unclear :')
 

·
Registered
Joined
·
156 Posts
Another question.

I am looking to order injectors.

With the swapping of the ecu and wiring harness, do I run the low impedance injectors found on usdm vehicles or am I still required to run high impedance injectors. Or am I crazy?
 

·
Registered
Joined
·
732 Posts
Anyone every have an issue with the wastegates not keeping up enough? I am running stock aristo ecu with the stock twins on a 3 inch straight pipe exhaust and 3 inch intake (2 1/2 inch intercooler piping.) I always stayed around 12 psi without an issue with a cheap ebay intercooler. I switched intercoolers from a cheap ebay unit, to a nice precision and my boost level now is 14.5-15psi and hits boost/fuel cut in 3rd and 4th gear under heavy load.

The wastegate seems to try to control the boost levels, but keeps creeping up on me. All my vacuum lines have been replaced and there are no leaks. Wondering if the intercooler/ exhaust/ intake combo just flows too much for my tall geared setup (R154 with stock 3.7 lsd rear end.) Any thoughts?

Really want to keep the stock twins for the oem sleeper look, but I can not deal with this boost cut!

Unplug the aristo map sensor. It isn't used anyway, We ran 22-25psi on the stock twins with our ranger making over 400HP for MONTHS!
 

·
Registered
Joined
·
35 Posts
Unplug the aristo map sensor. It isn't used anyway, We ran 22-25psi on the stock twins with our ranger making over 400HP for MONTHS!
22-25 psi on stock jdm twins or usdm?
i had the jdm twins and i over clocked them at 22 psi.
 

·
Registered
Joined
·
1 Posts
You are all going to hate me but I need help with my setup and getting it through inspection. I need help with getting this thing to pass inspection. The hook up to the OBD2 connection and take the reading for no codes and o2 sensor reading. It doesn't have a Maf sensor on it. Do I need on to pass or what so I need to do? The two codes are o2 sensor Which I read you can get a delet for that but what do I do with the Maf sensor code and what do I need to get rid of the code? New with this car and want to pass inspection. Is has a 8psi street tune.

02 IS300 with JDM 2jzgte vvt-I
Precision pt6765 single turbo swap
AEM ems v2 pnp dezod kit
AEM IAT sensor
AEM 3bar map sensor
With the old is300 ecu still in the car
 

·
Registered
Joined
·
156 Posts
Where did you guys get vacuum for the brake booster from. I am not sure if I am having a brake bleeding issue or vacuum issue. I am running vacuum from one of the outlets near the back of the manifold. I was trying to find a fitting to run it from the top of the manifold but didn't have any luck. I thought I bled the brakes well enough not to have an issue but I will check next. I want a solid vacuum source before I re-bleed
 

·
Registered
Joined
·
1,307 Posts
Where did you guys get vacuum for the brake booster from. I am not sure if I am having a brake bleeding issue or vacuum issue. I am running vacuum from one of the outlets near the back of the manifold. I was trying to find a fitting to run it from the top of the manifold but didn't have any luck. I thought I bled the brakes well enough not to have an issue but I will check next. I want a solid vacuum source before I re-bleed
Pretty sure any spot downstream of the throttle body will work as long as you have a check valve allowing only vacuum to the booster and no pressure.
 

·
Registered
Joined
·
22 Posts
I am finally about ready to drop in my 2jzgte aristo swap on factory 5 speed! Two questions, and yes I have read all 53, fifty-three, pages.

1.) Does anyone have a EMU basemap for is300 ecu, all factory settings with TTC, FMIC, 3" exhaust.

2.) Are there any photos of the o2 sensor set up? Including wiring splices.

Thanks guys.
 

·
Registered
Joined
·
1,307 Posts
I am finally about ready to drop in my 2jzgte aristo swap on factory 5 speed! Two questions, and yes I have read all 53, fifty-three, pages.

1.) Does anyone have a EMU basemap for is300 ecu, all factory settings with TTC, FMIC, 3" exhaust.

2.) Are there any photos of the o2 sensor set up? Including wiring splices.

Thanks guys.
I don't think I've even read all 53 pages. :)

For the o2 sensor, would be good to search for some dedicated threads, especially as it relates to the emanage or o2 sensor and turbo. You can extend wiring and splice in factory sensors, use universal ones, save yourself some hassle reducing number of o2 sensors you hook up, etc.

http://my.is/forums/f114/is300-2jzgte-swap-problem-solved-443287/

http://my.is/forums/f115/universal-o2-sensor-wiring-diagram-pin-out-360684/


The emanage map will depend on how you have it set up. There are threads like this out there

http://my.is/forums/f88/i-have-my-emanage-ultimate-now-what-do-i-do-w-298581/

http://my.is/forums/f114/collective-post-your-ems-maps-here-324359/
 
781 - 795 of 795 Posts
Top