Lexus IS Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
52 Posts
Discussion Starter · #1 ·
(Yes, I read the archives before posting)

2002 with under 100k miles -- started up the car the other day, A/C blowing cold, drove off and it suddenly stops working. All the dash control functions work as intended, I can see the servos, including the air mix, working just fine. When I toggle the A/C button I can feel the compressor load on the engine RPMs, the magnetic clutch is engaging, condenser fan turns on, and I don't hear any loud or metallic sounds coming from the compressor. Compressor clutch stays engaged and does not cycle on and off. Took it to the shop yesterday to get the refrigerant pressure checked and the charge was within specification, so I don't think I have a leak.

Any ideas?
 

·
Registered
Joined
·
1,354 Posts
Buy a new compressor. It’s broken.
Sounds like it.

All I was told is 110psi and that the refrigerant was full.
Not enough info. 110psi engine-off sounds about right, but when running, the high side oughtta be in the 150-175psi zone, and low side oughtta be in the 40-50psi zone.

My compressor failed at 130k miles. Pressure readings were 115psi on both sides with engine off and engine running with AC on... which indicates compressor wasn't doing anything at all.

FYI you cant (or at least shouldn't) change only a compressor; need to replace the compressor, expansion valve and condenser together - and flush out the lines and evaporator before reassembly. Costs about $500 in parts/supplies from rock auto.
 

·
Mr. Roo
Super Moderator
Joined
·
10,197 Posts
As the others have said, the compressor has died. It will still engage with the belt and drain the engine power, but will not compress anything.
Compressor is shot. I have seen some work if you run the rpm up high. Then they will work till turned off. But still boils down to bad compressor.
Mine did this until eventually that didn't work anymore either.
 
1 - 7 of 7 Posts
Top