Lexus IS Forum banner

1 - 13 of 13 Posts

·
Registered
Land cruiser bj62
Joined
·
9 Posts
Discussion Starter #1
Hi,

I don't know if this is the right forum to post this but what the heck :D.
so the problem with my 2j is that 1 of the cylinders is not firing.
to be more specific the 1st injector from the grill.

What i have done,
check the spark (working)
checked map sensor (working)
check the injectors (working)
i didn't check the crank sensor but i think its OK and working
check the distributor wires and spark plug connectors (working)

now what i did was i took out the injectors and checked them if they worked i found out one of them didn't so i replaced all of them to be safe but after fitting them 3 of the injectors weren't working so i replaced the 3 that weren't working with the 3 i took out earlier that worked, but then the 1st injector didn't work AGAIN so i then opened everything again and replaced it with another injector that worked and i also changed the position of the injector to 2nd cylinder and installed the new injector in place of 1st cylinder to check if the wiring was correct and i didn't have any issue with the spark plug to my surprise the 1st cylinder was working (it was the one with the issue) and the 2nd cylinder didn't work (the one in which i installed the new injector) okay now i am stuck i don't know what to do.

I consulted with a local mechanic and he said that the injector your installing in the engine is from a 4A or a 5A toyota engine idk.
Also the mechanic said that the 5 injectors that are installed and are working have the number 02 written on them and the injectors i am installing have the number 07 and 10 written on them.
He said install the same number injector and it'll work.
 

·
Registered
2002 Lexus IS300
Joined
·
1,006 Posts
Please for the love of god use a period! You jumped from injectors to spark plugs. From what I could gather from all that is that now you either have a bad connection on the spark plug or fuel injector harness?
 
  • Like
Reactions: Speedmaster91

·
Registered
Land cruiser bj62
Joined
·
9 Posts
Discussion Starter #3
Please for the love of god use a period! You jumped from injectors to spark plugs. From what I could gather from all that is that now you either have a bad connection on the spark plug or fuel injector harness?
I have checked the spark plug connection by connecting the plug lead from distributor to spark plug and starting the engine I see sparks from spark plug when It comes close the the engine head or some other grounded point on the body.

Soooo the spark plugs are firing.
 

·
Registered
Land cruiser bj62
Joined
·
9 Posts
Discussion Starter #4
Please for the love of god use a period! You jumped from injectors to spark plugs. From what I could gather from all that is that now you either have a bad connection on the spark plug or fuel injector harness?
How do I check the injector harness?
 

·
Registered
Land cruiser bj62
Joined
·
9 Posts
Discussion Starter #11
Check engine light. What is/are the code(s) you’re getting?
I have the engine installed in a land cruiser bj62.
I would have to wire up the engine light to check the engine codes.
I would guess since its my first time it would be difficult to wire it up.
Is there any other way to check the issue withoutessing with the ecu?
 

·
Registered
Land cruiser bj62
Joined
·
9 Posts
Discussion Starter #12
M
I have the engine installed in a land cruiser bj62.
I would have to wire up the engine light to check the engine codes.
I would guess since its my first time it would be difficult to wire it up.
Is there any other way to check the issue withoutessing with the ecu?
Engine light is working I think because on the bj62 there isn't any engine light because of the old technology.
But there is a filter light and I think that's the engine light since it shuts off after the engine starts.
 

·
Registered
Land cruiser bj62
Joined
·
9 Posts
Discussion Starter #13
Check engine light. What is/are the code(s) you’re getting?
I saw a video on youtube of someone jumping the wires on one of the ecu connectors on his supra.
The check engine light blinked in a sequence so you could match the code to error list.
 
1 - 13 of 13 Posts
Top