Lexus IS Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
2 months ago I bought an IS from a family friend. I've had no issues until 2 days ago.

I was driving to work and the car just seemed really down on power, i turned the car off

and she was definitely bogging down, it did not want to go over 3500 rpm and topped out

around 35mph. So like any reasonable person I hopped on the forums. I seen a ton of

threads saying clean your MAF and throttle body, so i did exactly that, and there was no

change. Then I thought about my rx8 and how it went into limp mode. But the IS isnt throwing

any codes, also she starts right up and has no rough idle. Any recommendations? thanks before hand.
 

·
Registered
Joined
·
2,357 Posts
2 months ago I bought an IS from a family friend. I've had no issues until 2 days ago.

I was driving to work and the car just seemed really down on power, i turned the car off

and she was definitely bogging down, it did not want to go over 3500 rpm and topped out

around 35mph. So like any reasonable person I hopped on the forums. I seen a ton of

threads saying clean your MAF and throttle body, so i did exactly that, and there was no

change. Then I thought about my rx8 and how it went into limp mode. But the IS isnt throwing

any codes, also she starts right up and has no rough idle. Any recommendations? thanks before hand.
Check the fuel pressure. It could also be a bad TPS or APP sensor on the throttle body.
 
1 - 4 of 4 Posts
Top