Lexus IS Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1 (Edited)
I put the tein s tech spring on 1.3 front 1.6 in rear. My upper control arms on both sides are hitting the inner fender. I have put new stock sturts in after i installed the springs. Everytime i hit a bump in the road it sounds like i ran over a brick. IT is really starting to get worse. Can you please help>>>>>..
 

·
Premium Member
Joined
·
10,234 Posts
Are you running aftermarket wheels/tires?
 

·
Premium Member
Joined
·
7,619 Posts
Two words - - Bump Stops
Did you put `em back?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #5
stock chrome rims 17" /// The man who installed them said that he ajusted them. It is all in the front of the car. It was in the left before it was lowered. Know that i got it lowered it is alot louder and harder. It like the control arm is making a impression in the body of the car...>>>
 

·
Registered
Joined
·
1,078 Posts
Why didn't you get it fix before you lowered it? Also, why are you so sure that the impact is from the control arm?
 

·
Premium Member
Joined
·
7,619 Posts
bump stops it is, my Jedi senses tell me...
 

·
Registered
Joined
·
10 Posts
Discussion Starter #9
I had someone professional put them in. He told me that he cut the bump stops back . ALso i really sould of got the problem fix before i lowered it. BUt i was thinking when i lowered it it would fix the problem. Also before it was very slighty happening also it was very quiet you really had to listen for it. Well we jacked the car up and we saw where the upper control arm is making a dent. Well i really don't know. I thought it was the shocks so i went and bought new ones. THat was not the problem. Everything is stock...>>>
 

·
Registered
Joined
·
15,585 Posts
I'll need to see some pics.... i dont see how the upper control arm can make contact with sheetmetal like you say it is... the control arm is still within the wheel diameter... the wheel would be hitting before the control arm...
 

·
Premium Member
Joined
·
10,234 Posts
^^agreed, if the upper arm hits anything it would hit the fender lining.
 

·
Premium Member
Joined
·
7,619 Posts
jenna1C6 said:
Well i have no idea what to do. :confused:
This sucks>>>
have it checked...
 

·
Premium Member
Joined
·
10,234 Posts
shoot us some pictures of what you're talking about.
 

·
Registered
Joined
·
453 Posts
I'm using the s-tech and stock shock combo and its been fine for me. but what i do know is that the moment i see or feel something wrong with my suspension i'll be switching to aftermarket in a blink of an eye.


i'm not too sure whats happening in this situation but if your having that problem and your on stock shocks i'd just say switch to aftermarket shocks...it may help.
 

·
Premium Member
Joined
·
7,619 Posts
Flipside408 said:
he'd mentioned that he placed the 1.6 springs at the rear. it should've been in the front right?
Tein S tech = 1.3" front and 1.57" rear...
 

·
Premium Member
Joined
·
5,701 Posts
maybe the nut that holds the shaft of the shock to the strut assembly is loose.
 
1 - 20 of 22 Posts
Top