Lexus IS Forum - Reply to Topic
Thread: Bad ECU help Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now



In order to be able to post messages on the Lexus IS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself. If your address is invalid, you will likely lose access to the site.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
04-04-2019 05:35 PM
01 SolarYellow That code is for cam position sensor not ECU. Go to a better shop if you do not know much about cars.
04-04-2019 03:49 PM
Griffey Lytle
Bad ECU help

Hey guys, I have a 2005 Lexus is300 I had issues with a check engine light and I was getting the code P0010. I fixed and repaired multiple things that could’ve given the code but the code was still there. I ended up taking it to a shop and they said I have a bad ECU. Do you guys have any insight or recommendations on what’s the best thing I should do now? Thanks

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome