Lexus IS Forum - Reply to Topic
Thread: Just Some NA Intake Mods Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now



In order to be able to post messages on the Lexus IS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself. If your address is invalid, you will likely lose access to the site.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
02-22-2019 10:15 AM
01 SolarYellow
Quote:
Originally Posted by Posh469 View Post
Damn those are sick~! Let me know if you ever come across another set!
Thanks for sharing Tobias! Happy Friday.
Try here. Have not used them before. But you could try them.

Sell Lexus IS300 Climate Control Rings A/C SXE10 Altezza Aluminum CNC Is 300 motorcycle in Edison, New Jersey, US, for US $79.99
02-22-2019 08:00 AM
Posh469
Quote:
Originally Posted by TobiasSing View Post
Oh snap, you saw one of my little secrets haha.

I got them here:

https://www.my.is/forums/f99/rare-cl...s-sold-475217/
Damn those are sick~! Let me know if you ever come across another set!
Thanks for sharing Tobias! Happy Friday.
02-19-2019 02:17 PM
TobiasSing
Quote:
Originally Posted by Posh469 View Post
Tobias! - Where did you find the chromie temp adjusting knobs?!
Oh snap, you saw one of my little secrets haha.

I got them here:

https://www.my.is/forums/f99/rare-cl...s-sold-475217/
02-19-2019 10:36 AM
Posh469 Tobias! - Where did you find the chromie temp adjusting knobs?!
02-19-2019 08:11 AM
lexa$$01 A screenshot of the IAT after I modded the factory airbox...think that's about as good as it gets!
02-17-2019 05:34 PM
lexa$$01 All finished up and back together!
02-15-2019 05:58 PM
lexa$$01
Quote:
Originally Posted by TobiasSing View Post
yeah the gauge is really old, got it used many years ago. But since I don't have a phone and never used an app, I gotta stick to old school methods lol
Haha, no worries, I wasn't bust'n chops or anything. Mine worked great while I had it...if it works...it works.
02-14-2019 02:32 PM
black86
Quote:
Originally Posted by TobiasSing View Post
yeah the gauge is really old, got it used many years ago. But since I don't have a phone and never used an app, I gotta stick to old school methods lol
love my scan gauge. I prefer a dedicated screen to monitor [emoji1417]

Sent from my Pixel 3 XL using Tapatalk
02-14-2019 02:30 PM
TobiasSing
Quote:
Originally Posted by lexa$$01 View Post
Ahhh, gotcha, I'll have to see if my modified stock set up does any better? Ahhh, damn, haven't seen one of those in a while. I had one in my old Pontiac GTP years ago-lol I just use my app on my phone for most of my scan work.
yeah the gauge is really old, got it used many years ago. But since I don't have a phone and never used an app, I gotta stick to old school methods lol
02-13-2019 06:01 PM
lexa$$01
Quote:
Originally Posted by TobiasSing View Post
My intake is the very wide-open SRT filter one lol. Still a "cold air" though. Any heat comes from the exhaust headers, so it doesn't matter where you put the filter, it's basically as cold as it's going to get.

As for the gauge, it's hard to see in the pic because I was going 70mph lol, but it's a ScanGuage II
Ahhh, gotcha, I'll have to see if my modified stock set up does any better? Ahhh, damn, haven't seen one of those in a while. I had one in my old Pontiac GTP years ago-lol I just use my app on my phone for most of my scan work.
02-13-2019 02:32 PM
TobiasSing
Quote:
Originally Posted by lexa$$01 View Post
Nice! Yeah, in my M3 (has a sealed ram air type intake), the IAT's usually hover right around ambient (or just a degree or two over) at speed, but my IS300 pretty consistently shows around 5* over ambient at speed. What kind of gauge is that btw?
My intake is the very wide-open SRT filter one lol. Still a "cold air" though. Any heat comes from the exhaust headers, so it doesn't matter where you put the filter, it's basically as cold as it's going to get.

As for the gauge, it's hard to see in the pic because I was going 70mph lol, but it's a ScanGuage II
02-13-2019 08:20 AM
lexa$$01
Quote:
Originally Posted by TobiasSing View Post
Interesting. My intake air temperature usually almost reads exactly as the outside temperature when moving

Nice! Yeah, in my M3 (has a sealed ram air type intake), the IAT's usually hover right around ambient (or just a degree or two over) at speed, but my IS300 pretty consistently shows around 5* over ambient at speed. What kind of gauge is that btw?
02-13-2019 08:17 AM
lexa$$01
Quote:
Originally Posted by black86 View Post
I have a stock box with an HPS silicon tube from the box to the TB and i gets no higher than +5F at speed but with just a 5 min idle it can jump +30F [emoji24]

Sent from my Pixel 3 XL using Tapatalk
Ya, that's about what I see too. I really don't spend too much time sitting in traffic (fortunately), so my IAT's usually only creep up about 20* over ambient max.
02-08-2019 03:40 PM
lexa$$01
Quote:
Originally Posted by mesooohoppy View Post
nice. do you by chance live in a really wet area? i could see this being a problem for people in very wet climates.
Nope, and itís a pretty convoluted path to the airbox filter already, so not too concerned about water getting into the engine...I would literally have to drive through flood like conditions to have any issues-lol
02-08-2019 02:43 PM
black86
Quote:
Originally Posted by lexa$$01 View Post
Hey man, yeah, sort of-lol. A buddy gave me an Injen SRI to try out and I did monitor temps through my OBDLink app on my phone, and the temps always ran about 5-10 degrees above ambient while driving...but would shoot up another 15-20 degrees after coming to a stop. They would always drop back to a few degrees over ambient at speed though. I don't have any data yet on this set modified factory set up, but I fully expect it to be just a little better than the Injen in regards to temps...I'm not sure that I'll necessarily see/feel any performance differences though?
I have a stock box with an HPS silicon tube from the box to the TB and i gets no higher than +5F at speed but with just a 5 min idle it can jump +30F [emoji24]

Sent from my Pixel 3 XL using Tapatalk
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome