Lexus is300 2004 - Lexus IS Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 07-04-2018, 12:17 PM Thread Starter
Newbie
 
Join Date: Jul 2018
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Lexus is300 2004

Hey guys I’m new to this forum just bought my car about three months ago had a lot of work done to it including new alternator and battery. So the other day I was driving and at high Rpms my battery light would come on so I was heading home then my wipers came on hella fast car shut off and smoke came out from gauge cluster. I pushed it off of road checked underneath hood everything looks like nothing happend. Once I moved to fuse box my alternator fuse was blown but nothing else then I checked the fuses on driver foot well and my ecu fuse along with other fuses were blown and on passenger foot well all those fuses were good. So replaced those tried to start but wont just cranks. I have power but my gauge cluster doesn’t turn on but headlights do. I also
Noticed my fuel pump doesn’t prime I need my car started so I can go to work does anyone know what I should do? I’m hoping my ecu didn’t fry. Anything helps
Brandon.langholff is offline  
Sponsored Links
Advertisement
 
Reply

  Lexus IS Forum > Owner's Forums > IS300 Owner's Forum

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Lexus IS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself. If your address is invalid, you will likely lose access to the site.

Email Address:
OR

Log-in











Current users viewing this Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
2004 Lexus IS300 Cat back Exhaust jkwon432 IS300 Owner's Forum 2 02-20-2017 07:17 PM
Acceleration / shifting challenge - resolved 2004 IS300 !! PaulOrr General Discussion 2 06-03-2016 04:35 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome