P0037 Check Engine Light - Lexus IS Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 7 (permalink) Old 01-31-2017, 03:22 PM Thread Starter
Newbie
 
Join Date: Sep 2016
Posts: 26
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
 
P0037 Check Engine Light

I looked up this code on here and all people are saying is to replace this sensor.. first I started off with P0031 and P0037 .. I replaced both Bank 1 sensors trying to get rid of the check engine light.. now P0037 came back.. I have all brand new Denson sensors and a brand new Lexus sensor for bank 2 sensor 2.. mechanic said that I might get p0037 again after he fixed it and I drove off and there it is again..! is it the wiring harness or maybe a faulty sensor? I just got a full new exhaust and I'm tired of still have a check engine light on. Please help!
Jared_is300 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 01-31-2017, 06:54 PM
Enthusiast
 
Join Date: Dec 2010
Location: Marietta
Posts: 1,453
Mentioned: 0 Post(s)
Tagged: 1 Thread(s)
Quoted: 339 Post(s)
           
New exhaust? What did you have done?
01 SolarYellow is offline  
post #3 of 7 (permalink) Old 01-31-2017, 07:03 PM
Cherisher
 
blkdout's Avatar
 
Join Date: Aug 2008
Location: Ohio
Posts: 4,800
Mentioned: 5 Post(s)
Tagged: 2 Thread(s)
Quoted: 631 Post(s)
           
^ same question. Stock or aftermarket?

I have the same code and picking up the sensor tomorrow.

'03 Wagon - Stock
'02 Sedan - Not Stock

"There's nothing like waiting and getting exactly what you want."
-Hiral
blkdout is offline  
 
post #4 of 7 (permalink) Old 01-31-2017, 08:28 PM
Follower
 
Join Date: Jul 2013
Posts: 675
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 70 Post(s)
           
reklipz is offline  
post #5 of 7 (permalink) Old 02-01-2017, 08:50 PM Thread Starter
Newbie
 
Join Date: Sep 2016
Posts: 26
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
 
Pace setter exhaust manifold, Denso sensors, Megan racing y pipe, Greddy Revolution RS (new version).. I actually got the light fixed the sensor was in the wrong bank ? Now I finally got it to pass emissions!
Jared_is300 is offline  
post #6 of 7 (permalink) Old 02-01-2017, 08:51 PM Thread Starter
Newbie
 
Join Date: Sep 2016
Posts: 26
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
 
Thank you for the help.. I fixed it now though.. all sensors should be fine no check engine light and got it to pass emissions
Jared_is300 is offline  
post #7 of 7 (permalink) Old 02-01-2017, 08:52 PM Thread Starter
Newbie
 
Join Date: Sep 2016
Posts: 26
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
 
Mine was in the wrong bank lol.. car drives sooo much better just with a new sensor lol.. maybe yours is faulty I guess it happens more than you think.. Denso ones come with like 1 year warranties
Jared_is300 is offline  
Sponsored Links
Advertisement
 
Reply

  Lexus IS Forum > 1st-Gen IS300 > General Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Lexus IS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself. If your address is invalid, you will likely lose access to the site.

Email Address:
OR

Log-in











Current users viewing this Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP!!! Check engine light &+ traction light on iSerg300 General Discussion 5 11-07-2016 11:58 AM
Low engine temp issues jwis300 General Discussion 4 10-25-2016 09:06 PM
IS250 2011, Engine light on Low fuel pressure Vann General Discussion 4 04-15-2016 04:21 AM
Check engine light is300 o2 sensor? HELP!!! micah275 General Discussion 8 02-09-2016 09:51 PM
Please help! Check engine light! chrisv41 General Discussion 2 12-03-2015 02:08 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome