Starter issues ? - Lexus IS Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 06-24-2009, 07:09 AM Thread Starter
Lurker
 
Join Date: Aug 2007
Posts: 84
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
           
Starter issues ?

Anyone every change the starter on a IS 350 ? If so was it very hard to do. My bendex seems to be slipping slightly and causing a clicking sound on occasion during start ups.Not every time but it now seems to be getting more frequent. My 07 has 86,000 miles on it. Thanks for any replies.
bret_bartley is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 06-24-2009, 08:50 AM
Altruist
 
Join Date: Sep 2005
Location: N. New Jersey
Posts: 3,752
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
           
Let me put this in a better suited section.

01 IS300T 21psi 2.00 60' [email protected] -current-
01 IS300T 17psi 1.64 60' [email protected] -RIP-
06 Audi S4 6MT daily driver
94 Supra Single Turbo 6spd. SOLD
diablooffire03 is offline  
post #3 of 3 (permalink) Old 06-25-2009, 09:12 AM Thread Starter
Lurker
 
Join Date: Aug 2007
Posts: 84
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
           
thanks I wasnt sure where to enter it.
bret_bartley is offline  
Sponsored Links
Advertisement
 
Reply

  Lexus IS Forum > Owner's Forums > IS350 Owner's Forum

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Lexus IS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself. If your address is invalid, you will likely lose access to the site.

Email Address:
OR

Log-in











Current users viewing this Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Starter? cosmicmonster General Discussion 0 01-26-2009 02:03 PM
BMW finally admits turbo lag issues on twin-turbo six, issues fix jruhi4 The Garage 2 11-18-2008 04:05 PM
starter. surface1030 Showroom 1 11-02-2004 06:00 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome