Question regarding ECU resetting - Lexus IS Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 03-26-2011, 11:23 PM Thread Starter
Lurker
 
Join Date: May 2010
Posts: 75
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
           
Question regarding ECU resetting

I been having some CEL problems as of late and it requires for me to reset the ECU when I think i have solved the problem. I have noticed when i reset the ECU and wait about 10 mins which i always do that when i turn on the car afterwards it would have a very weak idle and one time i disconnected the postive and negitive from the battery and it just stalled. Is this a normal thing for all of you that have a IS 350? Thanks.

Im currectly getting a code p0171 and p0174
MRSNAKE is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 03-27-2011, 08:51 AM
Immortal
 
Join Date: Aug 2009
Location: Pittsbugh PA
Posts: 19,540
Mentioned: 8 Post(s)
Tagged: 4 Thread(s)
Quoted: 78 Post(s)
           
it looks like those codes are for catalytic efficiency. may be result of bad gas. one thing i am sure of, never disconnect any of the battery terminals while the car is running. it makes the electrical system unstable and it can instantly kill the regulator in your alternator.

'02 IS300 MSM LSD
jasonm4 is offline  
post #3 of 6 (permalink) Old 03-27-2011, 09:27 AM Thread Starter
Lurker
 
Join Date: May 2010
Posts: 75
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
           
Thanks. I have never discounted the battery while the car was running. It has always been off but after resetting the ECU and turning the car on is it normal for it to idle so weak?

Also i have noticed that on cold starts the RPM keeps bouncing up and down for about 3-5 mins. I don't recall it doing that before.
MRSNAKE is offline  
 
post #4 of 6 (permalink) Old 03-27-2011, 09:53 AM
Immortal
 
Join Date: Aug 2009
Location: Pittsbugh PA
Posts: 19,540
Mentioned: 8 Post(s)
Tagged: 4 Thread(s)
Quoted: 78 Post(s)
           
idle should be around 750 +/-50 rpm. I know on a cold start the car will hold a high idle(above 1K and should come down after a few minutes). not sure why it would be boucing around upon startup. how low is your idle(while in park with hot engine)?

'02 IS300 MSM LSD
jasonm4 is offline  
post #5 of 6 (permalink) Old 03-29-2011, 01:25 PM Thread Starter
Lurker
 
Join Date: May 2010
Posts: 75
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
           
Good news I fixed the problem. The MAF sensor needed cleaning so I took it out and sprayed it with electric cleaner and let it dry on paper towel. Noticed lots of dirty came off it. I repeated this about 4 times until i saw it wasn't giving off anymore dirt. I let it dry for about a hour to make sure and installed it back. Reset the battery and the light hasn't come back. The bouncing was due to a dirty MAF sensor. Bounce is gone at start up and everything is good to go. I was lucky that the first thing i tried did the trick. I researched about 15 different things could of caused the lights come on. My plan was to try the cheapest solution and work my way up. LUCK~~!!
MRSNAKE is offline  
post #6 of 6 (permalink) Old 03-29-2011, 01:27 PM Thread Starter
Lurker
 
Join Date: May 2010
Posts: 75
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
           
O BTW after reinstalling the MAF sensor make sure you give a thin layer of OIL around the sensor after it is installed to give it a nice seal and prevent dirty from getting in.
MRSNAKE is offline  
Sponsored Links
Advertisement
 
Reply

  Lexus IS Forum > Owner's Forums > IS350 Owner's Forum

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Lexus IS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself. If your address is invalid, you will likely lose access to the site.

Email Address:
OR

Log-in











Current users viewing this Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
question about resetting the ecu... Rob_K Basic Help & Repair 13 07-31-2006 04:43 PM
A question on resetting the ecu and gas mileage stizlex General Discussion 7 11-11-2003 02:40 PM
ecu resetting? lexluger180 Go Fast Stuff 7 04-22-2003 04:40 AM
resetting ECU Adobo General Discussion 14 03-30-2002 05:42 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome