Help: Check engine VSC and traction control light came on after battery drain - Lexus IS Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 13 (permalink) Old 03-20-2011, 10:54 PM Thread Starter
Lurker
 
Join Date: May 2010
Posts: 73
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
           
Help: Check engine VSC and traction control light came on after battery drain

I forgot to disconnect the battery while in winter storage. Battery was drained all the way i had to get a boost. Same day the traction, VSC and check engine light came on. Can anyone help me as to what the problem may be? thank you. It is a IS 350 2006. I did a burn out today and the car went sideways and it feels like the breaking has changed. Seems like the break assists no longer works. I have tried resetting ECU few times and the lights always come back. Thank you.

-Snake
MRSNAKE is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 03-21-2011, 08:14 AM
Lurker
 
Join Date: Jul 2008
Location: Toronto, Canada
Posts: 105
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
           
Got your PM and replied...!

Check your voltage of your battery, a replacement might be needed.

Hoping it's just this simple... good luck!
Double_L is offline  
post #3 of 13 (permalink) Old 03-21-2011, 06:34 PM
Lurker
 
Join Date: Jun 2009
Posts: 67
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
           
i have an '06 is350 also and the same lights came on a few weeks ago. had it checked by my mechanic and he found that i had a faulty catalytic converter code p0430. took it to the dealer and it was fixed for free. it was still under the federal emissions warranty 8/80. now it runs great! have only 35,000 miles.
atv1953 is offline  
 
post #4 of 13 (permalink) Old 03-22-2011, 08:02 AM Thread Starter
Lurker
 
Join Date: May 2010
Posts: 73
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
           
Checked the battery it was at 12.6 and over 14 when it was on so that is fine. I am now hoping it is the gas cap LOL. I noticed when i opened it i did not hear that vacuum sound. I am hoping that is the problem.
MRSNAKE is offline  
post #5 of 13 (permalink) Old 03-22-2011, 08:09 AM
Lurker
 
Join Date: Jul 2008
Location: Toronto, Canada
Posts: 105
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
           
Gas cap usually triggers the CEL only... but never know.

Maybe you're having the same issue like atv1953, a faulty catalytic converter. Get your mechanic to pull the code just to confirm.

Good luck.
Double_L is offline  
post #6 of 13 (permalink) Old 03-22-2011, 05:27 PM Thread Starter
Lurker
 
Join Date: May 2010
Posts: 73
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
           
I found out today that one of the wires that leads to the battery ( postive side ) was not connected. So i connected it and all the lights went away only for it to return about a hour or so later. Now i am trying to reset the ECU with any luck the codes just needed to clear? But somehow I don't think it will be that easy.
MRSNAKE is offline  
post #7 of 13 (permalink) Old 03-26-2011, 08:25 PM Thread Starter
Lurker
 
Join Date: May 2010
Posts: 73
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
           
ok here is a update. I got the car scanned and here is the codes p0171 and p0174. I have a CAI Injen Intake on it. I remember it would make a cool hissing sound sometimes around the same RPM but now as soon as this problem happened I don't hear that sound at all. P0171 and P0174 is related to the intake system. Here is a list of possible problems that it could be.

1) Air Induction System
2)Injector Blockage
3) MAF
4) ECT Sensor
5) Fuel Pressure
6) Gas Leakage On Exhaust System
7) Open or Short In Heated Oxygen Sensor Bank 1 or 2 Sensor 1 Circut
8) Heated Oxygen Sensor Bank 1 or 2 Sensor 1
9) PCV
10)ECM

I have also researched why and how the Injen intake i have make that hissing sound as i think the 2 problems are related. This is what I found.

"Normally the sound comes from the idle air control valve solenoid or when
the air passes through the throttle body plate when it is slightly open causing the air
to whistle."

So now i am thinking it could be the problem is The throttle body plate . I have no idea what a air control valve solenoid is.

On the second time doing a scan I got a code CO 300. I have no idea what that is . Anyone know what a code CO 300 is?
MRSNAKE is offline  
post #8 of 13 (permalink) Old 03-29-2011, 01:49 PM Thread Starter
Lurker
 
Join Date: May 2010
Posts: 73
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
           
I fixed the problem it was a dirty MAP sensor. I took out the MAF sensor and cleaned it with electric spray. I repeated that step 4 times until i noticed it wasn't giving off anymore dirty on the paper towel while letting it dry. After installing it i reset the battery and the lights went away and never came back. O BTW makes sure to put a thin layer of oil around the MAP sensor after reinstalling to give it a nice seal to prevent dirty from getting in.
MRSNAKE is offline  
post #9 of 13 (permalink) Old 03-29-2011, 02:37 PM
Newbie
 
Join Date: Feb 2011
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
You're very fortunate that the solution was fairly simple. I bought an 08 IS350 with 30k miles a month ago and I had these lights come on Sunday night. Long story short, I'm getting a new engine.
AaronN is offline  
post #10 of 13 (permalink) Old 03-29-2011, 07:02 PM Thread Starter
Lurker
 
Join Date: May 2010
Posts: 73
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
           
Wow. Yes i feel lucky considering I am out of the warrenty. Good thing I tried it myself. The shop I go 2 was getting ready to milk me out of cash. He was like it doesn't need cleaning with electric cleaner just let me get a new part for you and we will install it. Good thing i did it myself saved good money and i'm very happy right now. The next step is to get a trottle body cleaning done and i want to learn how to do that myself also. Can't be that hard. If you guys know any do it your self links for trottle body cleaning let me know.
MRSNAKE is offline  
post #11 of 13 (permalink) Old 05-24-2011, 03:57 PM
Newbie
 
Join Date: May 2011
Location: Brooklyn NY
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Japanese cars tend to have these lights pop up when there is a battery problem

Last edited by cpruser; 05-25-2011 at 10:10 PM.
cpruser is offline  
post #12 of 13 (permalink) Old 05-24-2011, 03:59 PM
Newbie
 
Join Date: May 2011
Location: Brooklyn NY
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
by the way I had the same problem with the battery once, it died after getting tints done, and after a boost check engine and VCS came on, but they disappeared the next day.
cpruser is offline  
post #13 of 13 (permalink) Old 07-28-2015, 09:35 AM
Newbie
 
Join Date: Jul 2015
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
How to manually zero out steering angle sensor , due to alternator dead . Any body help .
Eg2006 is offline  
Sponsored Links
Advertisement
 
Reply

  Lexus IS Forum > Owner's Forums > IS350 Owner's Forum

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Lexus IS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself. If your address is invalid, you will likely lose access to the site.

Email Address:
OR

Log-in











Current users viewing this Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
VSC, Engine, and Traction Control light ON RML700 General Discussion 36 07-06-2015 04:57 PM
Check Engine Light + Traction Control ticklemechip IS300 Owner's Forum 7 06-17-2012 05:57 AM
Check Engine Light With Blinking Traction Control Light JustinK101 Basic Help & Repair 21 03-12-2012 12:26 PM
Flashing Check Engine w/Check VSC + Traction Control PJStyles IS250 Owner's Forum 6 08-16-2009 09:59 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome