Problems after full exhaust install - Lexus IS Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 05-14-2014, 09:53 AM Thread Starter
Newbie
 
Join Date: Sep 2006
Location: beach park, IL
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Problems after full exhaust install

I'm sorry if this was posted before but I couldn't find it. I recently put on KOspeed headers, megan downpipe, and greddy cat back, I already had the TS o2 delete in, but didn't put in the pre cat o2 sensors, so obviously the check engine light came on. The next day I put them in, and after awhile of driving the car started to stink (fuel like), and started bucking a bit. Had the trac light and engine light start flashing then. So I bought new precat sensors, reset battery and the same problem happened, took it to get codes read and had 4 misfires, autozone said spark plugs should fix it. So I had new plugs put in, and reset battery, and car still slightly bucks and still stinks...no check engine light yet though, but my question is, do I have to get the car tuned now because of that, or what could the problem be?? Help...please, oh yeah, 2002 is300 :-)
LEXOTA IS is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 05-14-2014, 11:58 AM
Lurker
 
Join Date: Jan 2014
Location: Louisville, ky
Posts: 121
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
           
What size hks? If you got the 3" with a cat delete 2.5" Megan mid pipe and headers then you don't have enough back pressure. I would try to take of the mid pipe itself and mount the stock one back on with aftermarket headers and exhaust, if that fixes your problem you know you didn't have enough back pressure, if that doesn't fix then.... Idk lol

1986.5 Toyota supra mkiii 1jzgte (sold)
2001 GGP auto NA-T SRT 2.75 ms3pro s366 ~550
2002 MSM 5sp 1JZ VVTi swap underway
Hakujohn is offline  
post #3 of 6 (permalink) Old 05-14-2014, 04:12 PM Thread Starter
Newbie
 
Join Date: Sep 2006
Location: beach park, IL
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Both the down pipe and headers are 2.25, I couldn't find the specs on greddy exhaust. I would assume 2.25 also, but no clue. And the stock pipes I chopped off, no goin back! =]
LEXOTA IS is offline  
 
post #4 of 6 (permalink) Old 05-14-2014, 06:10 PM
Lurker
 
Join Date: Jan 2014
Location: Louisville, ky
Posts: 121
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
           
I would unbolt the exhaust itself and check it's diameter to confirm it is smaller than 3", after that I would make sure your upstream o2 sensors are connected in the correct place on the o2 sim, I would then also clean your maf, your maf being clogged will cause the car to run extremely rich causing that gas smell and flooding creating misfires.

1986.5 Toyota supra mkiii 1jzgte (sold)
2001 GGP auto NA-T SRT 2.75 ms3pro s366 ~550
2002 MSM 5sp 1JZ VVTi swap underway
Hakujohn is offline  
post #5 of 6 (permalink) Old 05-15-2014, 08:43 AM Thread Starter
Newbie
 
Join Date: Sep 2006
Location: beach park, IL
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
So after another day of driving it, the smell went away and the sluggishness is lower, but now sparked the check engine light, so I'll get it checked and see. I'll see about checkin the exhaust size, but when I was putting it on, it didn't seem like 3", I work in a machine shop, so numbers by eye I'm fairly good at =] And when I put that sim on, my check engine light was on, and it shut it off, so I know that's good. I will check the maf tho next. Thanks for the advice!
LEXOTA IS is offline  
post #6 of 6 (permalink) Old 05-15-2014, 04:30 PM Thread Starter
Newbie
 
Join Date: Sep 2006
Location: beach park, IL
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
But has anyone had a full exhaust put on and have any problems??
LEXOTA IS is offline  
Sponsored Links
Advertisement
 
Reply

  Lexus IS Forum > Lexus IS > Basic Help & Repair

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Lexus IS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself. If your address is invalid, you will likely lose access to the site.

Email Address:
OR

Log-in











Current users viewing this Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Full o2 delete problems Wiims Go Fast Stuff 18 06-15-2009 07:26 PM
full drl problems Romyo247 Showroom 1 10-15-2004 11:03 PM
Full Clarion Install JustinK101 Mobiletronics 2 08-01-2004 10:50 AM
Need help for Install L-sportline full kit jjakkolim Showroom 9 11-12-2003 06:23 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome