My Is dosent rev past 3000 rpm - Lexus IS Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 06-12-2012, 11:22 PM Thread Starter
Newbie
 
Join Date: Jun 2012
Location: Atlanta
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
My Is dosent rev past 3000 rpm

Hey guys Im new to the Is scene , so I bought a 2001 Is 2 weeks ago and it dosent rev over 3000 rpm is stays at 3k RPM (even if u floor it) and then shifts. I took it to a tranny shop and they sead the tranny was good. One of the guys at the shop told me that is could be my ECU ? does the 2001 is have a separate computer just for the tranny ? And it also had a CEL but whenever i would hook it up to a scanner it would never connect to the scanner any Ideas why ? I just managed to erase the CEL for a little while.
Notic is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 06-12-2012, 11:35 PM
Aficionado
 
Join Date: Jun 2010
Location: Minnesota
Posts: 960
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
           
Take a rubber hammer and tap the cats in the y-pipe and headers. I had the same problem and it turn out to be a clogged cat in my headers. If it's a bad cat you will hear a high "TING" sound. If it's a deep thump sound that the cat is still good.
svv323 is offline  
post #3 of 5 (permalink) Old 06-13-2012, 01:32 AM
Immortal
 
Join Date: Aug 2009
Location: Pittsbugh PA
Posts: 19,540
Mentioned: 8 Post(s)
Tagged: 4 Thread(s)
Quoted: 78 Post(s)
           
A bad MAF will cause this too. See if you can read airflow on a scanner. Check your OBD fuse otherwise it said it "wasn't ready" because you had just previously erased the code. The scanning of the sensors resets after x many miles and x many startups. Don't erase them until you know what they are. They will lead you to the problem.

Edit: You could also be in limp mode and have a bad positioning sensor. Here is another same issue but was MAF. https://my.is/forums/f115/2001-wont-r...-reset-422425/

Need codes plz.

'02 IS300 MSM LSD

Last edited by jasonm4; 06-13-2012 at 03:21 AM.
jasonm4 is offline  
 
post #4 of 5 (permalink) Old 06-13-2012, 06:38 PM Thread Starter
Newbie
 
Join Date: Jun 2012
Location: Atlanta
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Thanks for the help guys.
Notic is offline  
post #5 of 5 (permalink) Old 06-17-2012, 03:34 PM
Newbie
 
Join Date: Mar 2012
Posts: 34
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
           
pull the battery for a little that happened to me when the clutch solenoid froze so reset it. see if that works if not bake your car with a torch if ur brave enough and check all your fluids. sounds like ur car is in safety mode. but usually cpu reset will do it.
narinn114 is offline  
Sponsored Links
Advertisement
 
Reply

  Lexus IS Forum > Lexus IS > Basic Help & Repair

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Lexus IS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself. If your address is invalid, you will likely lose access to the site.

Email Address:
OR

Log-in











Current users viewing this Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
omg why dosent this exist. wtf mikeystyles IS300 Owner's Forum 2 06-21-2010 11:13 PM
Installed neo ipod works great, but AM dosent roadruler General Discussion 0 03-29-2007 07:47 PM
ECL, Trac Off blinking, and no power past 3000 RPM? 2002YellowIS General Discussion 14 02-18-2003 10:01 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome