Multiple issues.. - Lexus IS Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 05-20-2014, 11:49 AM Thread Starter
Aficionado
 
Join Date: Sep 2010
Location: Smithtown, NY
Posts: 755
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 41 Post(s)
           
Garage
Multiple issues..

Hey all,

recently i was told my No. 2 LCAs were bad...i bought some used ones with decent bushings from a junk yard. I was also told my steering rack was "leaking" into one of the boots..i have yet to change the LCAs and steering rack as im compiling parts for a steering and suspension refresh. Recently my power steering has been has been whining (not loud, but noticeable) especially on full lock...

my steering wheel also struggles to return to straight coming off of a turn.

my question is, would it be safe to say that the lower ball joints, lcas, steering rack and the possibility of bad belts result in the sloppiness and noisy front suspensiom?

2002 MSM Sportcross
TEIN//Gita//Blitz//Pioneer//FIGS//Work

instagram - ellis300
ellis300 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 05-20-2014, 12:40 PM
Addict
 
mm71522's Avatar
 
Join Date: Dec 2011
Location: Inglewood, California
Posts: 2,664
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 353 Post(s)
           
Garage
Yeah sounds about right..I had a bad ball joint and my steering rack was leaking into one of the boots as well, so it sounds exactly like what you described..noisy front suspension, steering wheel would return after a turn. Driving it just didn't feel right anymore, and now that I replaced it all, new tires and alignment..it feels perfect again! I'm sure the bad LCAs are making it worse.

Mike
'02 AR IS300; M98 L-Tuned
TOKICO HP/TANABE NF210

ENKEI KOJIN 18X8.5+35/9.5+30
---------------------------------
DIY: Nav+Aftermarket HU
DIY: Timing Belt

My Thread
mm71522 is offline  
post #3 of 4 (permalink) Old 05-20-2014, 12:54 PM
Immortal
 
Join Date: Aug 2009
Location: Pittsbugh PA
Posts: 19,540
Mentioned: 8 Post(s)
Tagged: 4 Thread(s)
Quoted: 78 Post(s)
           
The lower ball joints and rack issue would give you the sloppiness as mm71522 mentioned and went through, but the whine at lock is pretty normal because the pump is pushing max pressure and I believe is releived by a check valve. Idle rpms should also bump up at lock as well, so that may be normal. It wouldn't be a serpentine belt issue unless it screaches and/or is cracked and old.

'02 IS300 MSM LSD
jasonm4 is offline  
 
post #4 of 4 (permalink) Old 05-20-2014, 01:32 PM Thread Starter
Aficionado
 
Join Date: Sep 2010
Location: Smithtown, NY
Posts: 755
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 41 Post(s)
           
Garage
Thanks guys. I always knew something wasn't right beyond what I already knew on the car, a second opinion eases the mind

2002 MSM Sportcross
TEIN//Gita//Blitz//Pioneer//FIGS//Work

instagram - ellis300
ellis300 is offline  
Sponsored Links
Advertisement
 
Reply

  Lexus IS Forum > Lexus IS > Basic Help & Repair

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Lexus IS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself. If your address is invalid, you will likely lose access to the site.

Email Address:
OR

Log-in











Current users viewing this Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Multiple issues with IS350, need help Sleepy1711 General Discussion 1 03-07-2013 07:08 PM
Why do i waste my time with this car.....(Cooling Issues) (now with Battery issues!) OKCIS Go Faster 70 06-01-2012 02:27 PM
Multiple issues on 2007 is350 Rowzter Basic Help & Repair 1 05-08-2012 10:50 AM
Multiple issues with my 2004 IS300 DSantos Basic Help & Repair 5 01-03-2012 06:38 PM
BMW finally admits turbo lag issues on twin-turbo six, issues fix jruhi4 The Garage 2 11-18-2008 04:05 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome