Missing part on engine ? - Lexus IS Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 05-10-2019, 02:54 PM Thread Starter
Newbie
 
Join Date: May 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Missing part on engine ?

Wondering what is supposed to be attached to these if anything. Just noticed while cleaning my car. Thanks for your help!
Attached Thumbnails
Click image for larger version

Name:	image_1557521422901.jpg
Views:	17
Size:	824.2 KB
ID:	124301   Click image for larger version

Name:	image_1557521615863.jpg
Views:	28
Size:	1.28 MB
ID:	124305   Click image for larger version

Name:	image_1557521644407.jpg
Views:	30
Size:	1.17 MB
ID:	124307  
Ikenzoc is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-10-2019, 03:03 PM
Frequenter
 
Join Date: Mar 2016
Posts: 235
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 88 Post(s)
 
Hodgdon Extreme is offline  
Sponsored Links
Advertisement
 
Reply

  Lexus IS Forum > Lexus IS > Basic Help & Repair

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Lexus IS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself. If your address is invalid, you will likely lose access to the site.

Email Address:
OR

Log-in











Current users viewing this Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
My love for IS300's jesuspuppy General Discussion 10 07-01-2019 03:00 PM
My engine is missing a piece help identify Christian Bossio Basic Help & Repair 4 03-23-2019 05:41 PM
Auto to Manual Swap, Wiring, Ecu, CC, NSS, CLSW, Trac, Snow, now smogged in CA! Curran Go Fast Stuff 186 01-05-2019 10:11 AM
missing part on my KW suspension collar arunanlogen Stop, Drop and Roll 2 06-27-2017 08:31 PM
Low engine temp issues jwis300 General Discussion 4 10-25-2016 09:06 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome