Is300 electrical problem - Lexus IS Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 03-30-2016, 07:11 PM Thread Starter
Newbie
 
Join Date: May 2013
Location: Ft. Washington MD
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
           
Is300 electrical problem

After filling the car up with gas I went to start it; she cranked over and immediately shut off; no lights, no power to anything but security light was flashing and the "door open" light was lite after I popped the hood.
Anyways I messed with the terminals, the negative one was actually loose tightened them both up and the car starts and runs fine again.
But now neither off my power outlets work, the radio works but no sound from the speakers. Anyone know whats going on?

02 GGP auto BC Racing 12k/10k
99 T/A M6 bolt ons
Archdogg is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 03-31-2016, 08:33 AM
Fiend
 
Join Date: Nov 2006
Location: Bowie
Posts: 474
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 50 Post(s)
           
Have you checked all your fuses

MY IS is Boosted with imagination by Sesame Street Performance (lol)
HKS DLI ignition box, PHR alternator 230amp or 250amp peak idk, Walbro 255lph fuel pump, Brain Crower 264 cams, SRT Intake with RaceECU, Fidinza adjustment Cam-gear Exhaust set 0, Mishimoto Engine&Trans radiator+hoses, megan racing y-pipe, OEM FRS 4.10 rear Torsen LSD diff, greddy EVO2 cat-back, SSR type CRS wheels, Tokico Illumina 5-way shocks, Cusco blue swaybars and chassis stiffiners..... Doin that all motor build
Poke_IS300 is offline  
post #3 of 3 (permalink) Old 03-31-2016, 02:00 PM Thread Starter
Newbie
 
Join Date: May 2013
Location: Ft. Washington MD
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
           
Ok I disconnected the battery, cleaned the terminals reconnected the battery now the speakers work again; the fuse for the cigarette lighter was blown, replaced that and everything is fine again. Thanks for the help

02 GGP auto BC Racing 12k/10k
99 T/A M6 bolt ons
Archdogg is offline  
Sponsored Links
Advertisement
 
Reply

  Lexus IS Forum > Lexus IS > Basic Help & Repair

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Lexus IS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself. If your address is invalid, you will likely lose access to the site.

Email Address:
OR

Log-in











Current users viewing this Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
IS300 fuel door release problem is3oo2k2 Basic Help & Repair 7 11-30-2017 10:52 AM
IS300 AEM Infinity problem lexus3hunna Go Faster 4 02-27-2016 05:22 PM
is300 transmission problem after rear end collision robertebaileyjr General Discussion 6 01-18-2016 07:14 PM
2001 IS300 battery problem duhbreadman General Discussion 7 12-17-2015 02:30 PM
New Member IS300 turbo phoenix19l General Discussion 5 11-30-2015 05:42 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome