Check Engine Light on after i washed the engine! HELP!! - Page 2 - Lexus IS Forum
User Tag List

Reply
 
LinkBack Thread Tools
post #16 of 23 (permalink) Old 05-07-2009, 07:45 PM
Dr. JDM
 
chado's Avatar
 
Join Date: Nov 2002
Location: Los Angeles
Posts: 9,332
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
           
i never had a problem after washing my engine

2003 GGP 5MT Fully Loaded - SOLD
2013 Porsche 911 Carerra
2007 Aston Martin V8 Vantage
2016 Mazda MX-5 Miata Launch Edition
chado is offline  
Sponsored Links
Advertisement
 
post #17 of 23 (permalink) Old 05-08-2009, 09:51 AM
Frequenter
 
Join Date: Dec 2008
Location: Mid-west
Posts: 204
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
           
Quote:
Originally Posted by chado View Post
i never had a problem after washing my engine
I wish I could say the same, I had washed it at least 4-5 days ago and now just getting this problem.

2001 IS300 Black/tan
| Apexi WS Coilovers | ISX50 Shift knob | OEM spoiler | 15% tint | Smoked sidemarkers |
shake is offline  
post #18 of 23 (permalink) Old 05-10-2009, 01:06 PM
Dr. JDM
 
chado's Avatar
 
Join Date: Nov 2002
Location: Los Angeles
Posts: 9,332
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
           
damn, it now has happened to me. DOH! washed the engine today...

CEL just blinks a few times but goes away. hopefully it will dry soon. driving just a little rough. i just replaced my spark plugs, too!

2003 GGP 5MT Fully Loaded - SOLD
2013 Porsche 911 Carerra
2007 Aston Martin V8 Vantage
2016 Mazda MX-5 Miata Launch Edition
chado is offline  
 
post #19 of 23 (permalink) Old 05-10-2009, 01:40 PM
Frequenter
 
Join Date: Mar 2007
Location: Los Angeles, CA
Posts: 232
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
           
Garage
I've been planning on washing my engine bay, but now after reading through this tread . . . . I don't know

2001 ASP IS300 E-Shift
L-Tuned sways - FIGS Hood Prop Kit - AAC Interior LEDs
airswoosh1 is offline  
post #20 of 23 (permalink) Old 05-10-2009, 02:33 PM
My.is Captain Kangaroo
 
-JDOG-'s Avatar
 
Join Date: Nov 2007
Location: With Jerry, Elaine, George, and Kramer at the Coffee Shop.
Posts: 4,246
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
           
I had a similer problem, but it was not a result from washing my engine bay.

My car would shake at idle and would accelerate feeling like it was going to stall, turned out to be a misfire in 3 cylinders.

But it could be anything, check your plugs.

©2006 my.IS

'02 Lexus IS300 MSM 5AT LSD - RIP
'08 Chevy Silverado 4x4 LS2 Swap - SOLD
'13 Subaru BRZ Limited 6 Spd - SOLD
'11 Mercedes-Benz E350 Black - SOLD
'07 Porsche Cayman S 6spd - SOLD
'03 Corvette Z06 - FOR SALE
'09 Lexus ISF - NEXT :)


"I don't always drive cars, but when I do. I prefer the IS300. Stay in third gear my friends."
-JDOG- is offline  
post #21 of 23 (permalink) Old 05-10-2009, 04:39 PM
Dr. JDM
 
chado's Avatar
 
Join Date: Nov 2002
Location: Los Angeles
Posts: 9,332
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
           
well after driving for about 20 miles everything has smoothed out but the CEL with trac off blinking remains. i'll probably reset the ECU in a few days. hopefully no damage was done.. just my luck, after all these years

got the codes read anyway:
P0306: cylinder 6 misfire detected
P0300: random cylinder misfire detected
P0303: cylinder 3 misfire detected

2003 GGP 5MT Fully Loaded - SOLD
2013 Porsche 911 Carerra
2007 Aston Martin V8 Vantage
2016 Mazda MX-5 Miata Launch Edition
chado is offline  
post #22 of 23 (permalink) Old 05-10-2009, 10:36 PM
Frequenter
 
Join Date: Dec 2008
Location: Mid-west
Posts: 204
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
           
Quote:
Originally Posted by chado View Post
damn, it now has happened to me. DOH! washed the engine today...

CEL just blinks a few times but goes away. hopefully it will dry soon. driving just a little rough. i just replaced my spark plugs, too!
Chado,I fixed my problem by getting a compressed air bottle thing and then I sprayed by the spark plugs after I took the main plasitc cover off. Then I parked it in the sun for at least 6 hours with the plastic cover off and hood open. I unplugged the battery for about 5 minutes and then put it back in and started the car. I let it "idle" for about 20 minutes and it finally smoothed out. It didn't do it by itself tho, when ever the idle got a little bumpy I gave it a little bit of gas....finally it went away tho. I'm never washing that engine bay with a hose again lol.

I was freaking out at first, but I'm glad it got solved for me. Hope it works out for you as well.

2001 IS300 Black/tan
| Apexi WS Coilovers | ISX50 Shift knob | OEM spoiler | 15% tint | Smoked sidemarkers |
shake is offline  
post #23 of 23 (permalink) Old 01-31-2019, 06:17 PM
Newbie
 
Join Date: Jan 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Car wash lead to check engine and other lights

Same scenario exactly when went thru car wash with my otherwise super running reliable Lexus 2007 purchasedin 2006 and loooove it still. Check engine light came on couldn’t accelerate and ugly rough slow ride . All lights on. Never happened with all same car wash before but misfire previously has happened and had spark plugs changed.will get codes but got home ok after I sat with engine off unable to get a AAA response so dry out definitely helped
arucatv is offline  
Sponsored Links
Advertisement
 
Reply

  Lexus IS Forum > Lexus IS > Basic Help & Repair

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Lexus IS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself. If your address is invalid, you will likely lose access to the site.

Email Address:
OR

Log-in











Current users viewing this Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
'07 IS250- Check Engine Light & Check VSC Message AllFiredUp IS250 Owner's Forum 4 05-18-2009 03:33 PM
Trac Off Light Blinks And Check Engine Light On thong84 General Discussion 5 12-07-2007 07:26 PM
engine light or check engine light worse? siren05 Basic Help & Repair 5 08-05-2006 04:27 PM
Check Engine light Came On After Engine wash! reidlos General Discussion 7 06-14-2006 01:31 PM
check engine light and trac light flashing and throttle prob Kapoosh Go Fast Stuff 7 08-24-2004 03:41 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome