A/C issue - Lexus IS Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 05-01-2014, 11:41 PM Thread Starter
Newbie
 
Join Date: May 2014
Location: So Cal
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
           
A/C issue

Hello,
my a/c blower fan stopped working and I suspect its the blower control module relay. All fuses are OK, the a/c light goes on when I turn the a/c on and I hear the compressor kicking in, but fan does not kick in. One odd thing is I checked the current running from relay module to blower motor and current is constantly at 12v even when a/c fan switch is off??? Anyone have any ideas.
Racsoman is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 05-02-2014, 10:05 AM
Frequenter
 
Join Date: Aug 2013
Location: Virginia
Posts: 132
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
           
If you have 12v and good ground @ blower motor the blower motor (fan) is bad.
IntensaBlue02 is offline  
post #3 of 3 (permalink) Old 05-16-2014, 01:16 AM Thread Starter
Newbie
 
Join Date: May 2014
Location: So Cal
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
           
Quote:
Originally Posted by IntensaBlue02 View Post
If you have 12v and good ground @ blower motor the blower motor (fan) is bad.
Thanks instensablue02. I checked the blower motor control module and found it to be defective. Bought a replacement part from Rock auto and I have cold air again . I've attached instruction page on what to check on the blower control module in case anyone has a similar problem.
Attached Files
File Type: pdf 30291d1305171243-blower-fan-quit-working-blower-motor-control-relay.pdf (23.1 KB, 81 views)
Racsoman is offline  
Sponsored Links
Advertisement
 
Reply

  Lexus IS Forum > Lexus IS > Basic Help & Repair

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Lexus IS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself. If your address is invalid, you will likely lose access to the site.

Email Address:
OR

Log-in











Current users viewing this Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
a/c issue Ryzies Basic Help & Repair 1 07-19-2013 08:03 AM
2001 IS300 NA-T AEM FIC Issue... ISSUE DXR Go Faster 113 05-19-2013 07:55 AM
Headlight Issue/Rear brake issue schrizzl Basic Help & Repair 2 11-19-2012 09:37 AM
Headlight issue or maybe power issue gqxphil Showroom 14 01-15-2011 12:54 AM
Camber issue and spring issue Aubie83 Stop, Drop and Roll 4 03-26-2003 09:20 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome